Menu icon Foundation
Downloading 5.4.1 incomplete

Everything seems to download, but the CSS files are employ. No styles just 2 empty lines in both CSS files.

I have tried downloading the compete package and a custom build in both Chrome and Safari. No luck.

Please advise.

5.4.1download

Everything seems to download, but the CSS files are employ. No styles just 2 empty lines in both CSS files.

I have tried downloading the compete package and a custom build in both Chrome and Safari. No luck.

Please advise.

Thomas E. Vasquez almost 5 years ago

Yep Dustin I noticed the same thing as well. I downloaded 5.4.1 in order to update WP-Forge, the WordPress theme I put together with Foundation and the css files are empty.

Probably just a hiccup.

Troy Baalham almost 5 years ago

Same problem here. Hopefully this will be fixed soon.

Jacqueline Chenault almost 5 years ago

I'm having a similar issue using the foundation-rails gem. Looks like none of the CSS styles are being loaded - when I take a look at even basic elements (IE H2 tags) in Firebug they have no style rules.

Michael Sneed almost 5 years ago

I was updating a project and noticed the homepage was spanning the whole screen and my aside fell under the main content area.. I lossed the 2 col layout I was doing. I then went file by file starting with the Foundation css file and noticed everything went crazy when I updated that file to the new release. I looked inside and 2 lines of nothing..

FYI I downloaded the "essentials" Foundation download and the css file was fine.

Hope they fix it soon!

Glad I found this out sooner rather than later...phew!

Vasilis Rapanakis almost 5 years ago

Yes same problem and it is my first time trying to use it. The essential CSS does not seem to be the same as the complete one (grid on the forms seems to be missing) can anyone point me to 5.4.0 download anywhere? Or should I just wait it out ?

Thomas E. Vasquez almost 5 years ago

@Vasilis you can download 5.4 from here https://github.com/zurb/foundation/releases - just click on the source code zip under 5.4

Rafi Benkual almost 5 years ago

We just pushed a temporary fix for this to get 5.4 css. There is an issue with the gruntfile and cdn paths we are tracking down.

Rafi Benkual almost 5 years ago

Thomas, the link you are pointing to is the docs and repo, this one will help people just copy/paste the css in https://github.com/zurb/bower-foundation/blob/master/css/foundation.css

Dustin Cook almost 5 years ago

Hey Rafi, Thanks for the temp fix.

Trayy Dee almost 5 years ago

Hi Rafi and all!

I'm new here on the forum, but not new to Foundation, which is best for my needs since v.3, when I found it.

Now I got a problem, same as you guys. Hopefully I found this post, because I was going creazy with the issue with incomplete CSS file.

1) correct me if I'm wrong, but using foundation.css as a temporary fix, make it impossible to work with "compass watch", because every time I edit a .scss file, app.css is recreated. So I end up with with app.css which has ~700 lines of code.

I made a short video screencast showing the issue on fresh project: http://screencast.com/t/mDHVmhDx

Is there any solution different than replacing css file?

UPDATE: I noticed new update to 5.4.3. Unfortunatelly, the problem with incomplete css file still exists.

Trayy Dee almost 5 years ago

It looks like at the moment Foundation does not work properly with SASS 3.4.x if you guys uninstall or downgrade to version 3.x.x it should work!

Vaughn D. Taylor almost 5 years ago

Has there been any resolution on this? I just installed 5.4.3 as well and the problem is not resolved.

@Trayy Dee, I watched your screencast. In bower_components/foundation/scss/foundation/ I have two bower json files > .bower.json and bower.json (dot at the beginning of first). In the .bower.json file, the version is showing as 5.4.3 and in the bower.json file the version is showing as 5.4.2. Shouldn't there only be one file here and which one is correct?

I'm reluctant to downgrade my SASS as recommended. Hopefully there will be a fix soon?

Vaughn D. Taylor almost 5 years ago

Uninstalling 3.4.x then reinstalling 3.3.x works for sure. To do this quickly:

Check version:

$ sass -v

If you have 3.4.x (using sudo):

$ sudo gem uninstall sass

To install the last 3.3.x release

$ sudo gem install sass -v 3.3.14

Thomas E. Vasquez almost 5 years ago

@Rafi, you are correct, but if you notice, Vasilis asked the following: "can anyone point me to 5.4.0 download anywhere?" which is what I did