Menu icon Foundation
Magellan - Wrong Active State on Page

I'm having oodles of issues with Magellan's active / non-active states. The active states activate on the incorrect anchor AND they don't follow the anchors well. It's almost irradic as sometimes the states work, and at others, they don't. This is a universal issue as I've seen this on multiple browsers.

I have a presentation tomorrow and would really love to have this incorporated into my presentation.

http://www.nathanfleischmann.com/CHASSE

I've done lots of online forum crawling and I see others having this issue, but no fix to it. Any ideas or suggestions (outside of removing Magellan Sticky nav)?

Magellanactive state

I'm having oodles of issues with Magellan's active / non-active states. The active states activate on the incorrect anchor AND they don't follow the anchors well. It's almost irradic as sometimes the states work, and at others, they don't. This is a universal issue as I've seen this on multiple browsers.

I have a presentation tomorrow and would really love to have this incorporated into my presentation.

http://www.nathanfleischmann.com/CHASSE

I've done lots of online forum crawling and I see others having this issue, but no fix to it. Any ideas or suggestions (outside of removing Magellan Sticky nav)?

Rafi Benkual about 5 years ago

Magellan will be going through a retooling which will improve functionality. There is an open issue on GitHub for this. It will be resolved there. https://github.com/zurb/foundation/issues/2198

In the meantime if anyone has a solution, feel free to submit a pull request and we'll see about adding it in.