Menu icon Foundation
Select styling not being rendered

Hi,

According to the docs - http://foundation.zurb.com/docs/components/forms.html - the should be rendered automatically.
I've tried adding:
@import "foundation";
@import "foundation/components/grid-5";
@import "foundation/components/forms";

But it doesn't get rendered anyway. What else is missing? The documentation should be more explicit about this.

Thank you.

cssformsselectrendering

Hi,

According to the docs - http://foundation.zurb.com/docs/components/forms.html - the should be rendered automatically.
I've tried adding:
@import "foundation";
@import "foundation/components/grid-5";
@import "foundation/components/forms";

But it doesn't get rendered anyway. What else is missing? The documentation should be more explicit about this.

Thank you.

Guido Grulke almost 6 years ago

is foundation working on your site and is it only the form rendering missing?
Make sure you insert the link to the foundation.css file - http://foundation.zurb.com/docs/css.html

Which kind of foundation config you're using (css, customized, ..)?
otherwise please let me know a little bit more about your config.
I've used the form styling today in my config and it works well.

Bruno Couto almost 6 years ago

I'm using the normal config I guess, with sass. I followed this steps:
http://foundation.zurb.com/docs/sass.html

The inputs seems to be styled correctly, but the select and also checkbox+label aren't.

I'm calling app.css:
HTML
<link rel="stylesheet" href="assets/css/app.css" />

and foundation js:
HTML
<script src="assets/bower_components/foundation/js/foundation.min.js"></script>
<script src="assets/scripts/app.js"></script>

This is my config.rb:
```Ruby
add_import_path "bower_components/foundation/scss"

Set this to the root of your project when deployed:

http_path = "/assets/"
css_dir = "css"
sass_dir = "css/_dev"
images_dir = "img"
javascripts_dir = "scripts"
```

This is my app.scss
SCSS
@import "settings";
@import "foundation";
@import "foundation/components/grid-5";
@import "foundation/components/forms";

What else may be missing?

Guido Grulke almost 6 years ago

I see - it is ruby - so I'm no longer in the game - sorry.

Bruno Couto almost 6 years ago

This isn't Ruby, I don't understand a thing about ruby too, it's just the config file for the sass environment.
I still haven't my selects and checkboxes + labels properly styled, everything else is ok. What's wrong here?

Bruno Couto almost 6 years ago

Hi,
I've just figured it out, I was compiling with compass app, which doesn't support Foundation 5.
Using 'compass watch' on the terminal solved it.
Thank you