Menu icon Foundation
Top Menu not working in mobile (Foundation Website)

Hi, I wanted to switch to foundation, so decided to take a look at the samples. The top navigation menu doesn't work all the time in mobile devices. I tested using Chrome on Android 4.3 (Galaxy S3) and browsed around the foundation docs page.

When it works, I get an off-canvas type vertical menu sliding in from the left, which is impressive, but then it will stop working randomly (after I scroll around the page a bit) and when I click the menu button (at top), it will just enter active state, but menu won't appear. Some times it won't work on first load itself.

I like the over-all feel of the framework very much and was wondering if this is a problem which has already been solved, but the designer's forgot to update their own website.

PS: It seems the problems are mainly occuring only when I am browsing the Foundation Docs pages (http://foundation.zurb.com/docs/).

menutoggle

Hi, I wanted to switch to foundation, so decided to take a look at the samples. The top navigation menu doesn't work all the time in mobile devices. I tested using Chrome on Android 4.3 (Galaxy S3) and browsed around the foundation docs page.

When it works, I get an off-canvas type vertical menu sliding in from the left, which is impressive, but then it will stop working randomly (after I scroll around the page a bit) and when I click the menu button (at top), it will just enter active state, but menu won't appear. Some times it won't work on first load itself.

I like the over-all feel of the framework very much and was wondering if this is a problem which has already been solved, but the designer's forgot to update their own website.

PS: It seems the problems are mainly occuring only when I am browsing the Foundation Docs pages (http://foundation.zurb.com/docs/).

Samuel Kelemen over 5 years ago

I've seen some issues with top bar before. Unfortunately, top bar isnt very friendly yet. I'll see if I can replicate this issue, and get back to you in few days.