Menu icon Foundation
Equalizer Height Changing

I'm having some problems with Equalizer. I'm using Equalizer on a row with the article in each div column having the data-equalizer-watch code in it. When you load the page it works perfectly and looks as it should nice and tight against the content however, hit refresh and it jumps in height by around 400px meaning the heights are increased greatly which is odd behavior, am I doing something wrong here? ( I tried to add some screenshots but the photo features doesn't seem to be working at the moment. )

<div class="row collapse" data-equalizer>
  <div class="large-4 columns">
    <article class="content" data-equalizer-watch>
      ...
    </article>
  </div>
  <div class="large-4 columns">
    <article class="content" data-equalizer-watch>
      ...
    </article>
  </div>
  <div class="large-4 columns">
    <article class="content" data-equalizer-watch>
      ...
    </article>
  </div>
</div>

         

First load

Refresh

Equalizerheightproblemnot workingerrorFoundation 5

I'm having some problems with Equalizer. I'm using Equalizer on a row with the article in each div column having the data-equalizer-watch code in it. When you load the page it works perfectly and looks as it should nice and tight against the content however, hit refresh and it jumps in height by around 400px meaning the heights are increased greatly which is odd behavior, am I doing something wrong here? ( I tried to add some screenshots but the photo features doesn't seem to be working at the moment. )

<div class="row collapse" data-equalizer>
  <div class="large-4 columns">
    <article class="content" data-equalizer-watch>
      ...
    </article>
  </div>
  <div class="large-4 columns">
    <article class="content" data-equalizer-watch>
      ...
    </article>
  </div>
  <div class="large-4 columns">
    <article class="content" data-equalizer-watch>
      ...
    </article>
  </div>
</div>

         

First load

Refresh
Wing-Hou Chan over 5 years ago

Hey Allan!

Hmmm, the screenshots may be helpful. If you could try and upload them again later that'd be great!

What would be even better, is that you could post a link to the site! It'd help finding the solution to the problem easier.

Allan Kendall over 5 years ago

Hi there,

I have now managed to post the screenshots of what I'm talking about, hopefully this will provide some insight into the oddity. I can't link to the site as I'm currently building in my local environment.