Menu icon Foundation
Orbit Slider - Problem with changing options

Hi,

I have a maybe stupid question: i am trying to change some options of the orbit slider, like the timer-speed, slide number text etc. What is the right way and place to do so? I did it directly in the foundation.orbit.js and uploaded it again on the server, but it doesnt have any effect at all, it still uses the standard options. I checked it twice if i uploaded the correct (changed) file in the right folder and the changed file is definetely there, but - no effect. How can i make it working?

Thanks very much!

OrbitsliderJava

Hi,

I have a maybe stupid question: i am trying to change some options of the orbit slider, like the timer-speed, slide number text etc. What is the right way and place to do so? I did it directly in the foundation.orbit.js and uploaded it again on the server, but it doesnt have any effect at all, it still uses the standard options. I checked it twice if i uploaded the correct (changed) file in the right folder and the changed file is definetely there, but - no effect. How can i make it working?

Thanks very much!

Wing-Hou Chan almost 6 years ago

Hi TMC77,

I would recommend checking you changed the right bit and check if the code is valid.

TMC77 almost 6 years ago

well i am guessing if the code wouldnt be valid it would not work at all, but it works just normal, but more "normal" than i want it to ;-)

for example i change the Speed time to 4000 instead of 10000, but it still changes only every 10000 miliseconds :-(

Wing-Hou Chan almost 6 years ago

Yea, that's true.

If you have loaded foundation.js, check your file path for foundation.orbit.js

If you have loaded the mini version (foundation.min.js), load foundation.js and foundation.orbit.js instead.

Meg C over 5 years ago

I have the same issue. And my path is correct. Any other ideas?

TMC77 did you solve it?

Elle Tolman over 5 years ago

I'd also like to chime in that I'm experiencing something similar.

I'm using Mixture and am only previewing my code locally, maybe a week ago ago my Orbit settings were in place and working correctly, and a couple of days ago I noticed that the timer, controls and numbers are showing again. I've checked my foundation.js and foundation.min.js and both show that I have settings in place that are not being reflected in my preview:

  • next on click: true (not working, nothing happens on click)
  • navigation arrows: true (not showing)
  • slide number: false (still showing)
  • bullets: true (can see them but when you click on them, it doesn't take you to a different slide)
  • timer: false (can still see timer and it's loading bar regardless of how long I set the timer speed)
  • swipe: true (not working)

Was there an update that changed how these files are read? New location?