Menu icon Foundation

My Posts

  • 2
    Replies
  • Formatting code snippets

    By David Barker

    code snippets

    Does Foundation include any way to format code snippets like in the Foundation documentation: http://foundation.zurb.com/docs/components/accordion.html I've created the css to style it as shown in the above link, but is there a quick way to replace all... (continued)

    Last Reply by David Barker about 5 years ago


My Comments

David Barker commented on Shannon Schärer's post over 3 years

I've had the same issue. I think it was caused as I had moved a project.
My solution:
In project.json it was pointing to the wrong directory, which seems to stop any projects in the same directory showing in Yeti. I updated the project to the correct directory by opening project.json and amending:
"name":"project-name","directory":"/the-path-to-my-project/my-project"....
Hope this might help someone.
NOTE: I am not a dev so I'm not 100% sure this was causing the issue, but it worked for me!

David Barker commented on Jacob Wolf's post over 3 years

I had the same issue today. downloaded via Foundation 6 via Yeti. Added the class .reveal-for-large but the z-index was -1.
Changed as stated above:
$offcanvas-zindex: 1;

David Barker commented on pixelkai's post about 5 years

Thanks this "nearly" worked for me.

Other codes worked but not the Font Awesome unicode such as: \f0d8

I found I had to specify the font family as well:

//The accordion is closed
.accordion-icon:before {
    font-family: FontAwesome; 
    content: "\f0d7";
}

Sorry not sure why my code comment isn't formatting correctly!

David Barker commented on David Barker's post about 5 years

Thanks!

On another note a lot of the syntax highlighters require you to escape certain html characters. I came across this tool that can automate the process:

http://www.htmlescape.net/htmlescape_tool.html

Posts Followed




Following

    No Content

Followers

My Posts


My Comments

You commented on Shannon Schärer's post over 3 years

I've had the same issue. I think it was caused as I had moved a project.
My solution:
In project.json it was pointing to the wrong directory, which seems to stop any projects in the same directory showing in Yeti. I updated the project to the correct directory by opening project.json and amending:
"name":"project-name","directory":"/the-path-to-my-project/my-project"....
Hope this might help someone.
NOTE: I am not a dev so I'm not 100% sure this was causing the issue, but it worked for me!

You commented on Jacob Wolf's post over 3 years

I had the same issue today. downloaded via Foundation 6 via Yeti. Added the class .reveal-for-large but the z-index was -1.
Changed as stated above:
$offcanvas-zindex: 1;

You commented on pixelkai's post about 5 years

Thanks this "nearly" worked for me.

Other codes worked but not the Font Awesome unicode such as: \f0d8

I found I had to specify the font family as well:

//The accordion is closed
.accordion-icon:before {
    font-family: FontAwesome; 
    content: "\f0d7";
}

Sorry not sure why my code comment isn't formatting correctly!

You commented on David Barker's post about 5 years

Thanks!

On another note a lot of the syntax highlighters require you to escape certain html characters. I came across this tool that can automate the process:

http://www.htmlescape.net/htmlescape_tool.html

Posts Followed

Following

  • No Content

Followers

  • No Content