Menu icon Foundation

My Posts

  • 2
    Replies
  • Orbit Do Not Show Bullet

    By Angela

    Orbitbullet

    For some reason, the bullets for this Orbit slider do not show itself. The ordered list 'orbit-bullets' inside 'orbit-bullets-container' is empty even though I have bullets equal to true in both the UL and the JavaScript.

    Last Reply by Angela almost 6 years ago



  • 4
    Replies
  • Offcanvas Behavior

    By Angela

    scrollingoff-canvasoffcanvas

    I have a right offcanvas and when I open the page, I am able to scroll to the right to see the menu as if it's part of the page (it shouldn't act so). Then, I am able to click the menu icon and toggle the offcanvas. Once I have toggled I'm no longer able... (continued)

    Last Reply by Angela almost 6 years ago


My Comments

Angela commented on Angela's post almost 6 years

Hi @Rafi,

I can only see the bullets after adding empty LIs inside the UL, but I only get the number of bullets correspond to the number of LIs I have added manually. I think this is because Foundation is called as soon as the page is loaded, but all of my images and LIs are loaded afterward, only one bullet is ever shown.
However, when I put off Foundation initialization until all the Ajax calls are finished, all of my contents are somehow erased and the UL remains the way it was as the hardcoded HTML.

In addition, adding an empty class this way somehow removes my 'scene-slides-container' class from the UL, leaving me with only 'orbit-slides-container' for styling...

Angela

Angela commented on Sebastian Anjenehm's post almost 6 years

I'm wondering the same thing myself

Angela commented on Angela's post almost 6 years

Thanks Alex, that does solve the problem.

Angela commented on Angela's post almost 6 years

Sorry for the late reply, I just push the code online for testing

Angela commented on Tim Martin's post almost 6 years

I see

Angela commented on Tim Martin's post almost 6 years

I'm having the exact same issue. On top of that, my fixed header became unfixed when opening the menu from the middle of the page

Posts Followed

No Content

Following

    No Content

Followers

My Posts




My Comments

You commented on Angela's post almost 6 years

Hi @Rafi,

I can only see the bullets after adding empty LIs inside the UL, but I only get the number of bullets correspond to the number of LIs I have added manually. I think this is because Foundation is called as soon as the page is loaded, but all of my images and LIs are loaded afterward, only one bullet is ever shown.
However, when I put off Foundation initialization until all the Ajax calls are finished, all of my contents are somehow erased and the UL remains the way it was as the hardcoded HTML.

In addition, adding an empty class this way somehow removes my 'scene-slides-container' class from the UL, leaving me with only 'orbit-slides-container' for styling...

Angela

You commented on Sebastian Anjenehm's post almost 6 years

I'm wondering the same thing myself

You commented on Angela's post almost 6 years

Thanks Alex, that does solve the problem.

You commented on Angela's post almost 6 years

Sorry for the late reply, I just push the code online for testing

You commented on Tim Martin's post almost 6 years

I see

You commented on Tim Martin's post almost 6 years

I'm having the exact same issue. On top of that, my fixed header became unfixed when opening the menu from the middle of the page

Posts Followed

No Content

Following

  • No Content

Followers

  • No Content