Menu icon Foundation

Developer

My Posts





  • 9
    Replies
  • Foundation is slow for me

    By Sven

    slowload time

    Hi, I'm more of a hobby developer and in the process of finding my way in to a suitable responsive workflow. Now I fiddled with the configurator before downloading and find that the page takes a huge amount of time to load (>10 seconds), no matter i... (continued)

    Last Reply by Karl Ward over 4 years ago


My Comments

Sven commented on Sven's post over 4 years

No one have any idea? :(

The 2nd issue I can solve with a workaround, but for the 1st I really don't have a clue of what could be causing it...

I already tried removing all other Javascript I have on that page, but to no effect...

Sven commented on Sven's post over 4 years

Ok, I think I fixed the 110px issue now too, by adding a div with 110px height for compensation.

Sven commented on Sven's post over 4 years

Oh yeah: and of course the issue which occurs at around 1015px. Thanks for pointing that out, Ivan.

Sven commented on Sven's post over 4 years

Hi you two and thanks for your helpful replies!

I've updated the page now and from my side the navigation seems to work as desired.
What I did was adding

[data-magellan-expedition-clone] { visibility:hidden; } 
.navigation{ position:fixed; }
body{ padding-top:110px }

to my CSS and updating the Javascript according to what you wrote.

However there is still one small issue: When scrolled all the way up, the navigation is 110px below the viewport top. I think this is due to the padding I gave the body in order to compensate for the now fixed .navigation class.
I'm trying to fix this at the moment and will post when I succeed... In the mean time, if you have any suggestions, I'll be glad to hear them :)

Sven commented on Sven's post about 5 years

Thanks for the replies. It is a shame that Orbit isn't made for doing that.

I like your approach, Steve, and will try it out!

Posts Followed

No Content

Following

    No Content

Followers

My Posts

My Comments

You commented on Sven's post over 4 years

No one have any idea? :(

The 2nd issue I can solve with a workaround, but for the 1st I really don't have a clue of what could be causing it...

I already tried removing all other Javascript I have on that page, but to no effect...

You commented on Sven's post over 4 years

Ok, I think I fixed the 110px issue now too, by adding a div with 110px height for compensation.

You commented on Sven's post over 4 years

Oh yeah: and of course the issue which occurs at around 1015px. Thanks for pointing that out, Ivan.

You commented on Sven's post over 4 years

Hi you two and thanks for your helpful replies!

I've updated the page now and from my side the navigation seems to work as desired.
What I did was adding

[data-magellan-expedition-clone] { visibility:hidden; } 
.navigation{ position:fixed; }
body{ padding-top:110px }

to my CSS and updating the Javascript according to what you wrote.

However there is still one small issue: When scrolled all the way up, the navigation is 110px below the viewport top. I think this is due to the padding I gave the body in order to compensate for the now fixed .navigation class.
I'm trying to fix this at the moment and will post when I succeed... In the mean time, if you have any suggestions, I'll be glad to hear them :)

You commented on Sven's post about 5 years

Thanks for the replies. It is a shame that Orbit isn't made for doing that.

I like your approach, Steve, and will try it out!

Posts Followed

No Content

Following

  • No Content

Followers

  • No Content