Menu icon Foundation

My Posts



My Comments

Harry Riyait commented on Harry Riyait's post about 5 years

Ok I solved this. Here is the explanation for anyone else working with F5 in a SharePoint 2013 custom HTML file that is converted to a Master.

I moved all my script inclusions from the head to the bottom of the page, as the very last things that load. This includes: Jquery, fastclick, custom.modernizr and foundation.min. This is followed by the Foundation initialiser script and lastly, the reveal trigger script.

I also made sure that the modal DIV's have data-reveal="reveal".

I hope that helps someone in a similar position.

Harry

Harry Riyait commented on Harry Riyait's post about 5 years

The data-reveal="reveal" (from the html modal snippet) is how I get the scripts to fire in a SharePoint page.

Harry Riyait commented on Harry Riyait's post about 5 years

Sorry I forgot to include the Modal markup:

        <div id="privacyModal" class="reveal-modal small ms-dialogHidden" data-reveal="reveal">

            <p>Content</p>

            <a class="close-reveal-modal">×</a>
        </div> 

Harry Riyait commented on Harry Riyait's post about 5 years

On further reading this looks like a problem with reveal in general in v5. I loaded v4 of foundation.min.js and it worked.

So I suppose the question is what is different withe reveal code in v5? Being a sharepoint master the scripts are referenced in the head and the foundation initialiser along with the rest of my scripts are just before the /html.

I wonder if ripping out the reveal js code out of the v4 file and putting it in the v5 version may be a workaround?

Posts Followed

No Content

Following

    No Content

Followers

My Posts

My Comments

You commented on Harry Riyait's post about 5 years

Ok I solved this. Here is the explanation for anyone else working with F5 in a SharePoint 2013 custom HTML file that is converted to a Master.

I moved all my script inclusions from the head to the bottom of the page, as the very last things that load. This includes: Jquery, fastclick, custom.modernizr and foundation.min. This is followed by the Foundation initialiser script and lastly, the reveal trigger script.

I also made sure that the modal DIV's have data-reveal="reveal".

I hope that helps someone in a similar position.

Harry

You commented on Harry Riyait's post about 5 years

The data-reveal="reveal" (from the html modal snippet) is how I get the scripts to fire in a SharePoint page.

You commented on Harry Riyait's post about 5 years

Sorry I forgot to include the Modal markup:

        <div id="privacyModal" class="reveal-modal small ms-dialogHidden" data-reveal="reveal">

            <p>Content</p>

            <a class="close-reveal-modal">×</a>
        </div> 

You commented on Harry Riyait's post about 5 years

On further reading this looks like a problem with reveal in general in v5. I loaded v4 of foundation.min.js and it worked.

So I suppose the question is what is different withe reveal code in v5? Being a sharepoint master the scripts are referenced in the head and the foundation initialiser along with the rest of my scripts are just before the /html.

I wonder if ripping out the reveal js code out of the v4 file and putting it in the v5 version may be a workaround?

Posts Followed

No Content

Following

  • No Content

Followers

  • No Content