Menu icon Foundation

My Posts

No Content

My Comments

Brian Findlay commented on Benni's post almost 5 years

See PR #5632 (https://github.com/zurb/foundation/pull/5632) for backwards incompatibilities in sass v3.4.0 (http://sass-lang.com/documentation/file.SASS_CHANGELOG.html).

If you make 3 minor changes to _functions.scss and _global.scss you should be able to run sass 3.4.0 and compass 1.0.0. Worked for me...

Brian Findlay commented on Miguel van den Branden's post about 5 years

Additionally, there appears to be a rounding operation being executed when setting values.

Consider this example, where the slider is perhaps intended to select a currency value (to the nearest cent):

<div class="range-slider" data-slider data-options="start: 1; end: 10; step: 0.01">
  <span class="range-slider-handle"></span>
  <span class="range-slider-active-segment"></span>
  <input type="hidden">
</div>

This slider will indeed select values with 1-cent steps. However, using javascript to set the values to a non-integer number will not work.

This javascript...
Javascript
$('div.range-slider').foundation('slider', 'set_value', 5.01);

...results in setting the slider value to 5, not 5.01.

Brian Findlay commented on Miguel van den Branden's post about 5 years

I've observed this as well.

The example in the documentation would be expected to yield a slider with a range of 1-10, but instead yields one with a range of 0-9.

<div class="range-slider" data-slider data-options="start: 1; end: 10;">
  <span class="range-slider-handle"></span>
  <span class="range-slider-active-segment"></span>
  <input type="hidden">
</div>

Was very excited to see this component included in release 5.2, but will have to stick with nouislider until this is fixed (which I'm sure will be very soon). Thanks.

Posts Followed


Following

    No Content

Followers

My Posts

No Content

My Comments

You commented on Benni's post almost 5 years

See PR #5632 (https://github.com/zurb/foundation/pull/5632) for backwards incompatibilities in sass v3.4.0 (http://sass-lang.com/documentation/file.SASS_CHANGELOG.html).

If you make 3 minor changes to _functions.scss and _global.scss you should be able to run sass 3.4.0 and compass 1.0.0. Worked for me...

You commented on Miguel van den Branden's post about 5 years

Additionally, there appears to be a rounding operation being executed when setting values.

Consider this example, where the slider is perhaps intended to select a currency value (to the nearest cent):

<div class="range-slider" data-slider data-options="start: 1; end: 10; step: 0.01">
  <span class="range-slider-handle"></span>
  <span class="range-slider-active-segment"></span>
  <input type="hidden">
</div>

This slider will indeed select values with 1-cent steps. However, using javascript to set the values to a non-integer number will not work.

This javascript...
Javascript
$('div.range-slider').foundation('slider', 'set_value', 5.01);

...results in setting the slider value to 5, not 5.01.

You commented on Miguel van den Branden's post about 5 years

I've observed this as well.

The example in the documentation would be expected to yield a slider with a range of 1-10, but instead yields one with a range of 0-9.

<div class="range-slider" data-slider data-options="start: 1; end: 10;">
  <span class="range-slider-handle"></span>
  <span class="range-slider-active-segment"></span>
  <input type="hidden">
</div>

Was very excited to see this component included in release 5.2, but will have to stick with nouislider until this is fixed (which I'm sure will be very soon). Thanks.

Posts Followed


Following

  • No Content

Followers

  • No Content