Menu icon Foundation

Designer | Durham, UK.

My Posts





My Comments

Andrew Brown commented on Andrew Brown's post almost 6 years

Hmm, perhaps I'm over-complicating this in my head?

I'll give that a go and report back.

Thanks very much for your time.

Andrew Brown commented on Andrew Brown's post almost 6 years

Anybody have any support on this?

Andrew Brown commented on Peter Graff's post almost 6 years

Does anyone have any insight, however, on how to use them together - in the way that they have on their site?

Andrew Brown commented on Andrew Brown's post almost 6 years

Okay, so I can display code in a comment here but not in an original post. Weird. This is how that code should look:

<div class="off-canvas-wrap">
    <div class="inner-wrap">    

        <nav class="tab-bar">
            <section class="left-small">
                <a class="left-off-canvas-toggle menu-icon" ><span></span></a>
            </section>
            <section class="middle tab-bar-section">
                <h1 class="title">Foundation</h1>
            </section>
            <section class="right-small">
                <a class="right-off-canvas-toggle menu-icon" ><span></span></a>
            </section>
        </nav>

        <aside class="left-off-canvas-menu">
            <ul class="off-canvas-list">
                <li><label>Foundation</label></li>
                <li><a href="#">The Psychohistorians</a></li>
            </ul>
        </aside>

        <aside class="right-off-canvas-menu">
            <ul class="off-canvas-list">
                <li><label>Users</label></li>
                <li><a href="#">Hari Seldon</a></li>
            </ul>
        </aside>

        <section class="main-section">
            <!-- content goes here -->
        </section>

        <a class="exit-off-canvas"></a>

    </div>
</div>

Andrew Brown commented on Andrew Brown's post almost 6 years

Is there anyone can comment on this, please?

Andrew Brown commented on Andrew Brown's post almost 6 years

Thanks guys.

Courteny Elizabeth - where did you find that code? Is it your own and is it on GitHub? Thanks so much for sharing it.

Andrew Brown commented on Andrew Brown's post almost 6 years

Hey Sam. Yeah I seem to be discovering that the only difference with the jQuery versions is the legacy browser support, so I may not even need to call jQuery 2.0 in any case. Have opened another thread in the hope that I'll get some confirmation on that, but it seems ti be so.

I've not found any issues, just wanted to avoid running into them if they were known :)

Andrew Brown commented on Andrew Brown's post almost 6 years

Thanks for the reply Sam.

I need to try and maintain no conflicts between the version of jQuery being loaded with Foundation and the WP Core version, mainly because of plugins. I create themes for clients but some then go off and add their own plugins at times - not to mention that some of the plugins I use may need to reference the WP Core version.

I'm familiar with wp_deregister_script, wp_register_script and wp_enqueue_script, but also I think it's just good practice to not load additional versions to avoid potential issues ( see for example this from Pippin: http://pippinsplugins.com/why-loading-your-own-jquery-is-irresponsible/ ).

I'm just looking for a good and reliable way to make sure that there are no conflicts - but I'm struggling to find it.

Any further help from anyone would be greatly appreciated.

Best wishes, Andrew.

Posts Followed




Following

    No Content

Followers

  • Ben has no published posts

My Posts

My Comments

You commented on Andrew Brown's post almost 6 years

Hmm, perhaps I'm over-complicating this in my head?

I'll give that a go and report back.

Thanks very much for your time.

You commented on Andrew Brown's post almost 6 years

Anybody have any support on this?

You commented on Peter Graff's post almost 6 years

Does anyone have any insight, however, on how to use them together - in the way that they have on their site?

You commented on Andrew Brown's post almost 6 years

Okay, so I can display code in a comment here but not in an original post. Weird. This is how that code should look:

<div class="off-canvas-wrap">
    <div class="inner-wrap">    

        <nav class="tab-bar">
            <section class="left-small">
                <a class="left-off-canvas-toggle menu-icon" ><span></span></a>
            </section>
            <section class="middle tab-bar-section">
                <h1 class="title">Foundation</h1>
            </section>
            <section class="right-small">
                <a class="right-off-canvas-toggle menu-icon" ><span></span></a>
            </section>
        </nav>

        <aside class="left-off-canvas-menu">
            <ul class="off-canvas-list">
                <li><label>Foundation</label></li>
                <li><a href="#">The Psychohistorians</a></li>
            </ul>
        </aside>

        <aside class="right-off-canvas-menu">
            <ul class="off-canvas-list">
                <li><label>Users</label></li>
                <li><a href="#">Hari Seldon</a></li>
            </ul>
        </aside>

        <section class="main-section">
            <!-- content goes here -->
        </section>

        <a class="exit-off-canvas"></a>

    </div>
</div>

You commented on Andrew Brown's post almost 6 years

Is there anyone can comment on this, please?

You commented on Andrew Brown's post almost 6 years

Thanks guys.

Courteny Elizabeth - where did you find that code? Is it your own and is it on GitHub? Thanks so much for sharing it.

You commented on Andrew Brown's post almost 6 years

Hey Sam. Yeah I seem to be discovering that the only difference with the jQuery versions is the legacy browser support, so I may not even need to call jQuery 2.0 in any case. Have opened another thread in the hope that I'll get some confirmation on that, but it seems ti be so.

I've not found any issues, just wanted to avoid running into them if they were known :)

You commented on Andrew Brown's post almost 6 years

Thanks for the reply Sam.

I need to try and maintain no conflicts between the version of jQuery being loaded with Foundation and the WP Core version, mainly because of plugins. I create themes for clients but some then go off and add their own plugins at times - not to mention that some of the plugins I use may need to reference the WP Core version.

I'm familiar with wp_deregister_script, wp_register_script and wp_enqueue_script, but also I think it's just good practice to not load additional versions to avoid potential issues ( see for example this from Pippin: http://pippinsplugins.com/why-loading-your-own-jquery-is-irresponsible/ ).

I'm just looking for a good and reliable way to make sure that there are no conflicts - but I'm struggling to find it.

Any further help from anyone would be greatly appreciated.

Best wishes, Andrew.

Posts Followed

Following

  • No Content

Followers

  • Ben has no published posts