Menu icon Foundation

Developer | Newark, NJ

Just another brave human doing his best at diving into the world of Web Development, which by the way is absolutely nothing wrong with it. In fact is one of the most satisfying feeling ever. Planning into learn much more about ZURB Foundation in order to use this magnificent Framework as my main go to in order to creat awesome websites.

My Posts


My Comments

giovanni rivera commented on Tom Rohrbach's post 5 months

I have a similar question, In my case everything works but when I set the data-animation-out and actually clse the reveal the page do not want to scroll anymore and I have to refresh the page, but if I remove the data-animation-out and jus use the data-animation-in  the page scroll normal when closing the reveal. that is very strange....
This is the page link Im testing 
 
 
This is the code I'm using. By the way I'm using the ZURB-template
 
HTML
<div class="reveal large" id="image{{@index}}" data-reveal data-animation-in="gallery-in" data-animation-out="gallery-out">
<button class="close-button" data-close type="button">
<span aria-hidden="true">&times;</span>
</button>
<img class="modal-img" src="{{this.url}}" alt="">
</div>
 
CSS
.gallery-in {
@include mui-animation(slide(in, down), fade(in));
animation-duration: 1.5s;
}
.gallery-out {
@include mui-animation(slide(out, up), fade(out));
animation-duration: 1.5s;
}

giovanni rivera commented on RCD's post 5 months

If I'm correct your are missing to identified the toggle, like so data-toggle="main-menu"

giovanni rivera commented on Martin's post 5 months

I'm having continuous problem installing sweetalert2. Every time I try I get this error  Not Found: [email protected] mo matter how I do this still get the same error windows and mac. With the previous version I was successful but not anymore. Any reason why is this happening webpack maybe?
 
I was able to install sweetalert2 on a custom empty folder with just npm init and than npm install sweetalert2 but on a foundation-zurb template folder no success. 

giovanni rivera commented on Patrick Holzer's post over 1 year

 Hey Patrick I see that you are using waypoints I've try this so many time and no luck waypoint or wow.js 

giovanni rivera commented on Shane Sheppard's post over 1 year

 How were you able to implement waypoints into Foundation-ZURB?
I try so many different ways and no luck

giovanni rivera commented on Edgardo's post over 1 year

You welcome!Yeah I know there is no sudo is just the scripts I use to overcome my situation. I hope you find a solution is vI was about to install Foundation on my Windows PC and start looking for the easy way to do it. That's how I found your post.  

giovanni rivera commented on Edgardo's post over 1 year

If I'm not mistaking this has to do with permissions. I was having the same issue, bu in Mac OS hopefully hopefully you guys can find how to run these scripts on cmdPrompt on Windows:
 
sudo chown -R $USER:$GROUP ~/.npmsudo chown -R $USER:$GROUP ~/.config
 
Running those scrip on Terminal in my Mac solve the problem, never done it on Windows but I'm pretty there has to be a way to write them in cmpPrompt.
 
Forum Of Dsicucssion

giovanni rivera commented on Patricia MacDonnell Moss's post over 1 year

I'm getting the same warnings apparently is nothing to worry about for the moment. It is not an error is just a warning about some changes into Sass 4.0 I think that Foundation-CLI at this point is still using  Sass 3. Here is a link on a small addressed to this discussion.
 
Link to discussion

Posts Followed





Following

    No Content

Followers

My Posts

My Comments

You commented on Tom Rohrbach's post 5 months

I have a similar question, In my case everything works but when I set the data-animation-out and actually clse the reveal the page do not want to scroll anymore and I have to refresh the page, but if I remove the data-animation-out and jus use the data-animation-in  the page scroll normal when closing the reveal. that is very strange....
This is the page link Im testing 
 
 
This is the code I'm using. By the way I'm using the ZURB-template
 
HTML
<div class="reveal large" id="image{{@index}}" data-reveal data-animation-in="gallery-in" data-animation-out="gallery-out">
<button class="close-button" data-close type="button">
<span aria-hidden="true">&times;</span>
</button>
<img class="modal-img" src="{{this.url}}" alt="">
</div>
 
CSS
.gallery-in {
@include mui-animation(slide(in, down), fade(in));
animation-duration: 1.5s;
}
.gallery-out {
@include mui-animation(slide(out, up), fade(out));
animation-duration: 1.5s;
}

You commented on RCD's post 5 months

If I'm correct your are missing to identified the toggle, like so data-toggle="main-menu"

You commented on Martin's post 5 months

I'm having continuous problem installing sweetalert2. Every time I try I get this error  Not Found: [email protected] mo matter how I do this still get the same error windows and mac. With the previous version I was successful but not anymore. Any reason why is this happening webpack maybe?
 
I was able to install sweetalert2 on a custom empty folder with just npm init and than npm install sweetalert2 but on a foundation-zurb template folder no success. 

You commented on Patrick Holzer's post over 1 year

 Hey Patrick I see that you are using waypoints I've try this so many time and no luck waypoint or wow.js 

You commented on Shane Sheppard's post over 1 year

 How were you able to implement waypoints into Foundation-ZURB?
I try so many different ways and no luck

You commented on Edgardo's post over 1 year

You welcome!Yeah I know there is no sudo is just the scripts I use to overcome my situation. I hope you find a solution is vI was about to install Foundation on my Windows PC and start looking for the easy way to do it. That's how I found your post.  

You commented on Edgardo's post over 1 year

If I'm not mistaking this has to do with permissions. I was having the same issue, bu in Mac OS hopefully hopefully you guys can find how to run these scripts on cmdPrompt on Windows:
 
sudo chown -R $USER:$GROUP ~/.npmsudo chown -R $USER:$GROUP ~/.config
 
Running those scrip on Terminal in my Mac solve the problem, never done it on Windows but I'm pretty there has to be a way to write them in cmpPrompt.
 
Forum Of Dsicucssion

You commented on Patricia MacDonnell Moss's post over 1 year

I'm getting the same warnings apparently is nothing to worry about for the moment. It is not an error is just a warning about some changes into Sass 4.0 I think that Foundation-CLI at this point is still using  Sass 3. Here is a link on a small addressed to this discussion.
 
Link to discussion

Posts Followed

Following

  • No Content

Followers

  • No Content