Menu icon Foundation

My Posts



My Comments

Jared McMorris commented on Jared McMorris's post about 5 years

Update 2 - Determined that there was a typo in my CSS that was being compensated for by FireFox and Chrome, fixed the typo and everything is working again. Thanks for reading :)

Jared McMorris commented on Jared McMorris's post about 5 years

Update, after looking into it further, it seems to be an issue with Safari, and not the iPad breakpoint specifically. I just loaded the site in Safari on my desktop and I am experiencing the same layout/styling issues there. The website is loading perfectly in Chrome and FireFox, any ideas why it would be messed up in Safari?

Jared McMorris commented on James Cocker's post over 5 years

The media query polyfill seems to work for me, but I just cannot get the REM one to work. The only way I can get REMs to work is to go into the Foundation CSS and do a search/replace for REM with EM, but this messes up some of my layout.

Jared McMorris commented on Jared McMorris's post over 5 years

Issue resolved thanks to NikhilKalige: https://github.com/zurb/foundation/issues/4532

Jared McMorris commented on Abby Jones's post over 5 years

Me again,

I got a response on the Foundation GitHub repo and the user NikhilKalige was able to resolve the issue for me: https://github.com/zurb/foundation/issues/4532

Basically what you have to do is open foundation.min.js and search for the following line:

 t.preventDefault(), r.closeall.call(r), (!n.is_hover || Modernizr.touch) && r.toggle(e(this))

And replace it with this:

 t.preventDefault(), (!n.is_hover || Modernizr.touch) && r.toggle(e(this))

Hope this helps!

Jared McMorris commented on Abby Jones's post over 5 years

Hi Abby,

Not sure if you're using anything else out of Foundation, but I found that if I downgrade to Foundation 4, the toggle on click feature works exactly as it should without modifying any code. Unfortunately this is not a valid solution for me since I am using off-canvas navigation that is rendered useless when using Foundation 4, but maybe it will work for you.

In the meantime, I will continue looking for a solution to the issue with Foundation 5.

Jared McMorris commented on Abby Jones's post over 5 years

Same problem here, and no it is not the intended behavior. The intended behavior is that you should be able to click the parent element to both open and close the dropdown menu. As Abby stated, it functions in this manner on the demo site, but for whatever reason it doesn't work when put into practice.

Jared McMorris commented on Jared McMorris's post over 5 years

I actually posted on SO before posting here, didn't get any responses though. I'll report back if I find a solution, thanks!

Posts Followed

No Content

Following

    No Content

Followers

My Posts

My Comments

You commented on Jared McMorris's post about 5 years

Update 2 - Determined that there was a typo in my CSS that was being compensated for by FireFox and Chrome, fixed the typo and everything is working again. Thanks for reading :)

You commented on Jared McMorris's post about 5 years

Update, after looking into it further, it seems to be an issue with Safari, and not the iPad breakpoint specifically. I just loaded the site in Safari on my desktop and I am experiencing the same layout/styling issues there. The website is loading perfectly in Chrome and FireFox, any ideas why it would be messed up in Safari?

You commented on James Cocker's post over 5 years

The media query polyfill seems to work for me, but I just cannot get the REM one to work. The only way I can get REMs to work is to go into the Foundation CSS and do a search/replace for REM with EM, but this messes up some of my layout.

You commented on Jared McMorris's post over 5 years

Issue resolved thanks to NikhilKalige: https://github.com/zurb/foundation/issues/4532

You commented on Abby Jones's post over 5 years

Me again,

I got a response on the Foundation GitHub repo and the user NikhilKalige was able to resolve the issue for me: https://github.com/zurb/foundation/issues/4532

Basically what you have to do is open foundation.min.js and search for the following line:

 t.preventDefault(), r.closeall.call(r), (!n.is_hover || Modernizr.touch) && r.toggle(e(this))

And replace it with this:

 t.preventDefault(), (!n.is_hover || Modernizr.touch) && r.toggle(e(this))

Hope this helps!

You commented on Abby Jones's post over 5 years

Hi Abby,

Not sure if you're using anything else out of Foundation, but I found that if I downgrade to Foundation 4, the toggle on click feature works exactly as it should without modifying any code. Unfortunately this is not a valid solution for me since I am using off-canvas navigation that is rendered useless when using Foundation 4, but maybe it will work for you.

In the meantime, I will continue looking for a solution to the issue with Foundation 5.

You commented on Abby Jones's post over 5 years

Same problem here, and no it is not the intended behavior. The intended behavior is that you should be able to click the parent element to both open and close the dropdown menu. As Abby stated, it functions in this manner on the demo site, but for whatever reason it doesn't work when put into practice.

You commented on Jared McMorris's post over 5 years

I actually posted on SO before posting here, didn't get any responses though. I'll report back if I find a solution, thanks!

Posts Followed

No Content

Following

  • No Content

Followers

  • No Content