Menu icon Foundation

Developer

My Posts

  • 2
    Replies
  • Block grid in XY Grid

    By Danni

    xy gridblock grid

    Previously we can setup block grid as follow: <div class="row small-up-1 medium-up-2 large-up-4"> <div class="column"> <!-- Card --> </div> <div class="column"> <!-- Card --> </div> </di... (continued)

    Last Reply by Danni over 2 years ago




  • 2
    Replies
  • Button hover effect on 5.3.1

    By Danni

    buttonhover

    Button hover effect on Foundation 5.3.1 seems always using primary color, check the following sites and hover on alert/secondary/success button. http://foundation.zurb.com/docs/components/buttons.html http://wpforge.themeawesome.com/foundation-buttons

    Last Reply by Danni about 5 years ago


My Comments

Danni commented on Danni's post over 2 years

"Previous way of defining block grid was definitely easier."
agree.
 
Still familiarizing myself to the grid thou but thanks for the answer!

Danni commented on Rafi Benkual's post over 3 years

@Rafi Benkual for responsive toggle not working turns out in my scss\app.scss is not including foundation-menu-icon

so by putting

@include foundation-menu-icon

under @include foundation-menu;

problem solved.

Danni commented on Rafi Benkual's post over 3 years

@Laurent i have same issue but turns out in my case the tabs id and data-tabs-content is using different name (notice the login-tabs and example-tabs) in the snippet below.

    <ul class="tabs" data-tabs id="login-tabs">
      <li class="tabs-title is-active"><a href="#panel1" aria-selected="true">Create Account</a></li>
      <li class="tabs-title"><a href="#panel2">Register</a></li>
    </ul>      
    <div class="tabs-content" data-tabs-content="example-tabs">

@Rafi Benkual Just create a new project using Foundation 6.2 either via cli or clone the repo & running npm/bower install, but it seems the scss/_settings.scss is from 6.1, I mean there's no new setting such as foundation-pallete etc.

And the responsive toogle is not working.

Danni commented on Danni's post over 3 years

"When you install a new Foundation project, you should get the 6.2 settings file right away."

This is what im talking about. Its a new project created by foundation cli but the _settings.scss is same as 6.1.2, no $foundation-pallete etc.

Danni commented on cartz's post almost 4 years

in my case, closable callout not working because I exclude motion-ui :D

Danni commented on Joe Windeknecht's post almost 4 years

<nav class="column row">
  <div class="top-bar">
    ...
  </div>
</nav>

or (for full width nav color)

<nav class="top-bar">
  <div class="row column">
    ...
  </div>
</div>

reference : https://github.com/zurb/foundation-sites/issues/7325

Danni commented on Danni's post about 4 years

You're right, my bad :)

Thanks !

Danni commented on Danni's post about 4 years

nope. thats not working.

Danni commented on Clay Hymas's post about 5 years

I dont think its included by default. But integration is easy thou, i just put the slick folder in root and add

<link rel="stylesheet" type="text/css" href="slick/slick.css"/>
<script type="text/javascript" src="slick/slick.min.js"></script>

in my HTML file.

Danni commented on Danni's post about 5 years

Hi Rafi,

I've already use that fix.

thanks,

Posts Followed


  • 2
    Replies
  • closable callout

    By cartz

    callout closable

    Is there any known bug, that causes the closable callout not to work? I am not able to get it done :( even just by copying the code from the docs. Ordinary modals work very well...

    Last Reply by Danni almost 4 years ago



Following

    No Content

Followers

My Posts




My Comments

You commented on Danni's post over 2 years

"Previous way of defining block grid was definitely easier."
agree.
 
Still familiarizing myself to the grid thou but thanks for the answer!

You commented on Rafi Benkual's post over 3 years

@Rafi Benkual for responsive toggle not working turns out in my scss\app.scss is not including foundation-menu-icon

so by putting

@include foundation-menu-icon

under @include foundation-menu;

problem solved.

You commented on Rafi Benkual's post over 3 years

@Laurent i have same issue but turns out in my case the tabs id and data-tabs-content is using different name (notice the login-tabs and example-tabs) in the snippet below.

    <ul class="tabs" data-tabs id="login-tabs">
      <li class="tabs-title is-active"><a href="#panel1" aria-selected="true">Create Account</a></li>
      <li class="tabs-title"><a href="#panel2">Register</a></li>
    </ul>      
    <div class="tabs-content" data-tabs-content="example-tabs">

@Rafi Benkual Just create a new project using Foundation 6.2 either via cli or clone the repo & running npm/bower install, but it seems the scss/_settings.scss is from 6.1, I mean there's no new setting such as foundation-pallete etc.

And the responsive toogle is not working.

You commented on Danni's post over 3 years

"When you install a new Foundation project, you should get the 6.2 settings file right away."

This is what im talking about. Its a new project created by foundation cli but the _settings.scss is same as 6.1.2, no $foundation-pallete etc.

You commented on cartz's post almost 4 years

in my case, closable callout not working because I exclude motion-ui :D

You commented on Joe Windeknecht's post almost 4 years

<nav class="column row">
  <div class="top-bar">
    ...
  </div>
</nav>

or (for full width nav color)

<nav class="top-bar">
  <div class="row column">
    ...
  </div>
</div>

reference : https://github.com/zurb/foundation-sites/issues/7325

You commented on Danni's post about 4 years

You're right, my bad :)

Thanks !

You commented on Danni's post about 4 years

nope. thats not working.

You commented on Clay Hymas's post about 5 years

I dont think its included by default. But integration is easy thou, i just put the slick folder in root and add

<link rel="stylesheet" type="text/css" href="slick/slick.css"/>
<script type="text/javascript" src="slick/slick.min.js"></script>

in my HTML file.

You commented on Danni's post about 5 years

Hi Rafi,

I've already use that fix.

thanks,

Posts Followed

Following

  • No Content

Followers

  • No Content