Menu icon Foundation

My Posts





  • 8
    Replies
  • npm run litmus without aws

    By Scott Bickell

    npmlitmusAWS

    Currently this command fires off a litmus test but ALSO requires an Amazon Web Services account. Doesn't work without it. npm run litmus I host my own images and I don't need the AWS part, only the Litmus test functionality. I tried to hack a few o... (continued)

    Last Reply by mxeise about 3 years ago


My Comments

Scott Bickell commented on Evan Wiegand's post almost 3 years

This situation has improved greatly for me using node 7.4.0 and npm 4.1.2 on MacOS.
Still takes a few seconds (less than 10), but that's better than 45.

Scott Bickell commented on Evan Wiegand's post about 3 years

Ugh! I have this exact same issue on two different computers. I've been living with it for months! I really wish I knew how to fix it. Major slowdown in my productivity. Anybody know how to fix this?

Scott Bickell commented on Scott Bickell's post over 3 years

Replacing the src folder seems to work fine.

Scott Bickell commented on Scott Bickell's post over 3 years

Thanks Corey for your input. Super helpful.
I'm surprised the the update process is so janky. Probably easier for me to just create a brand new project, delete the src folder and replace it with the src folder from my existing, outdated project. Seems like that should work, but I haven't tried it yet.

Scott Bickell commented on Scott Bickell's post over 3 years

I go back to my original position: I'd prefer the option to be able to skip AWS entirely. It is adding extra layers of unnecessary complexity for me and many questions remain about the proper config settings of AWS bucket permissions.
Right now, I'd like to be able to use something that I know works (manual image upload via FTP to my server)

Scott Bickell commented on Scott Bickell's post over 3 years

Actually, I'm unclear on how the AWS part is supposed to work. I was only able to get things working if I manually uploaded the images to my AWS bucket, then hard coded the img path into config.json
I seem to have permissions issues on the AWS side so I'm off to tinker with that.

Scott Bickell commented on Scott Bickell's post over 3 years

@Rafi I tried removing that block, but npm didn't like that. Seemed like setting up a AWS account would be the easier route, and it was. Works like a champ. Very cool to see this all working. Well done.

Posts Followed


Following

    No Content

Followers

My Posts

My Comments

You commented on Evan Wiegand's post almost 3 years

This situation has improved greatly for me using node 7.4.0 and npm 4.1.2 on MacOS.
Still takes a few seconds (less than 10), but that's better than 45.

You commented on Evan Wiegand's post about 3 years

Ugh! I have this exact same issue on two different computers. I've been living with it for months! I really wish I knew how to fix it. Major slowdown in my productivity. Anybody know how to fix this?

You commented on Scott Bickell's post over 3 years

Replacing the src folder seems to work fine.

You commented on Scott Bickell's post over 3 years

Thanks Corey for your input. Super helpful.
I'm surprised the the update process is so janky. Probably easier for me to just create a brand new project, delete the src folder and replace it with the src folder from my existing, outdated project. Seems like that should work, but I haven't tried it yet.

You commented on Scott Bickell's post over 3 years

I go back to my original position: I'd prefer the option to be able to skip AWS entirely. It is adding extra layers of unnecessary complexity for me and many questions remain about the proper config settings of AWS bucket permissions.
Right now, I'd like to be able to use something that I know works (manual image upload via FTP to my server)

You commented on Scott Bickell's post over 3 years

Actually, I'm unclear on how the AWS part is supposed to work. I was only able to get things working if I manually uploaded the images to my AWS bucket, then hard coded the img path into config.json
I seem to have permissions issues on the AWS side so I'm off to tinker with that.

You commented on Scott Bickell's post over 3 years

@Rafi I tried removing that block, but npm didn't like that. Seemed like setting up a AWS account would be the easier route, and it was. Works like a champ. Very cool to see this all working. Well done.

Posts Followed

Following

  • No Content

Followers