Menu icon Foundation

Developer

My Posts


  • 9
    Replies
  • Problem creating color palette

    By Sharriff

    PaletteSass

    According to the 6.2 docs, one can define a color palette, a step towards making a site "themable"(http://foundation.zurb.com/sites/docs/global.html#colors). As a test, I proceeded to create a test project using the foundation CLI with the "basic" temp... (continued)

    Last Reply by Rafi Benkual over 3 years ago


My Comments

Sharriff commented on Sharriff's post almost 3 years

I wonder why this is not showing up in the form

Sharriff commented on Sharriff's post over 3 years

It works now, thanks @Remco Janssen . This must be reflected in the docs. Should I file an issue at the foundation-cli github project?

Sharriff commented on Sharriff's post over 3 years

Here is my global section:

$global-font-size: 100%;
$global-width: rem-calc(1200);
$global-lineheight: 1.5;
$foundation-palette: (
  primary: #E44347,
  mars: #D7525C,
  saturn: #E4B884,
  neptune: #5147D7,
);
$light-gray: #e6e6e6;
$medium-gray: #cacaca;
$dark-gray: #8a8a8a;
$black: #0a0a0a;
$white: #fefefe;
$body-background: $white;
$body-font-color: $black;
$body-font-family: 'Helvetica Neue', Helvetica, Roboto, Arial, sans-serif;
$body-antialiased: true;
$global-margin: 1rem;
$global-padding: 1rem;
$global-weight-normal: normal;
$global-weight-bold: bold;
$global-radius: 0;
$global-text-direction: ltr;
$global-flexbox: false;
$print-transparent-backgrounds: true;

@include add-foundation-colors;
Error in plugin 'sass'
Message:
    scss/_settings.scss
Error: Undefined variable: "$success-color".
        on line 391 of scss/_settings.scss
>> $meter-fill-good: $success-color;
   ------------------^

Why would I need to restart my server @Rafi Benkual ? I am getting this error by running the Gulp "sass" task.

Sharriff commented on Sharriff's post over 3 years

Please try the example in the docs with a semi colon. It does not make a difference, still does not work. I mentioned that the missing semi colon was a copy/paste error on my part for the use of this posting

Sharriff commented on Sharriff's post over 3 years

Thanks for looking into this issue @Remco Janssen . The missing semi-colon does not change the output. It still fails with an error. I just pasted a quick copy in my post. It was not missing in my real code.

It could be that I have to retain the primary, secondary, error and alert classes. But the docs suggest in the case of the palette otherwise. My code is directly lifted off the docs page.

Posts Followed

No Content

Following

    No Content

Followers

My Posts



My Comments

You commented on Sharriff's post almost 3 years

I wonder why this is not showing up in the form

You commented on Sharriff's post over 3 years

It works now, thanks @Remco Janssen . This must be reflected in the docs. Should I file an issue at the foundation-cli github project?

You commented on Sharriff's post over 3 years

Here is my global section:

$global-font-size: 100%;
$global-width: rem-calc(1200);
$global-lineheight: 1.5;
$foundation-palette: (
  primary: #E44347,
  mars: #D7525C,
  saturn: #E4B884,
  neptune: #5147D7,
);
$light-gray: #e6e6e6;
$medium-gray: #cacaca;
$dark-gray: #8a8a8a;
$black: #0a0a0a;
$white: #fefefe;
$body-background: $white;
$body-font-color: $black;
$body-font-family: 'Helvetica Neue', Helvetica, Roboto, Arial, sans-serif;
$body-antialiased: true;
$global-margin: 1rem;
$global-padding: 1rem;
$global-weight-normal: normal;
$global-weight-bold: bold;
$global-radius: 0;
$global-text-direction: ltr;
$global-flexbox: false;
$print-transparent-backgrounds: true;

@include add-foundation-colors;
Error in plugin 'sass'
Message:
    scss/_settings.scss
Error: Undefined variable: "$success-color".
        on line 391 of scss/_settings.scss
>> $meter-fill-good: $success-color;
   ------------------^

Why would I need to restart my server @Rafi Benkual ? I am getting this error by running the Gulp "sass" task.

You commented on Sharriff's post over 3 years

Please try the example in the docs with a semi colon. It does not make a difference, still does not work. I mentioned that the missing semi colon was a copy/paste error on my part for the use of this posting

You commented on Sharriff's post over 3 years

Thanks for looking into this issue @Remco Janssen . The missing semi-colon does not change the output. It still fails with an error. I just pasted a quick copy in my post. It was not missing in my real code.

It could be that I have to retain the primary, secondary, error and alert classes. But the docs suggest in the case of the palette otherwise. My code is directly lifted off the docs page.

Posts Followed

No Content

Following

  • No Content

Followers

  • No Content