Menu icon Foundation

Developer | chicago

My Posts

  • 3
    Replies
  • Align-Center?

    By John Stephanites

    centeringfoundation 6.4.1

    I want to alignone image in the center of cell in each of the three cells that are in one row/container of header/banner. Align-center doesn't do this. I end up only being able to use text-center to achieve any manipulation at all. Please enligh... (continued)

    Last Reply by cs joshi over 1 year ago




  • 2
    Replies
  • Yeti

    By John Stephanites

    yeti

    TheYeti page says this---"You can choose between a standard Sass Foundation project or our ZURB Development Stack that will compile your Sass into CSS and give you Handlebars templating, UglifyJS (compress JavaScript), UnCSS (remove unused CSS), and image... (continued)

    Last Reply by John Stephanites almost 4 years ago




My Comments

John Stephanites commented on Zurb Rules's post over 2 years

I was having the same problem but with JPEG. Align-middle on the parent didn't work. I finally used text-center on the direct parent div and that worked. I don't know why because I had tried that but when I changed the whole parent grid from grid-margin-x to grid-padding-x it worked. 

John Stephanites commented on John Stephanites's post over 2 years

As it turns out it is very simple. I wanted to center some text in a div and all you do is add a class="text-center". Or if using Flexbox .   https://codepen.io/rafibomb/pen/YNerMQ
.flex-container {
text-align: center;

}

John Stephanites commented on John Stephanites's post over 2 years

I just said I found the answer.

John Stephanites commented on John Stephanites's post over 2 years

It has nothing on that page about centering like I am talking about. I actually found the answer using Dash by Kapeli. I do not know how to get to those kind of docs from the foundation site.

John Stephanites commented on Ryan Patterson's post over 2 years

Would a loop work? Every time slide one fires then restart?  I don't know as my JS skills suck but just wondering.

John Stephanites commented on Derek Paul's post over 2 years

I have been running into problems lately with the gulp process not recognizing my chances. Sometimes I have to go as far as shutting it down and restarting and even that doesn't work. Sounds very similar. If you figure it out let me know please. Thanks.

John Stephanites commented on Derek Paul's post over 2 years

I put the _custom.scss in the src-> assets->scss folder and then you need to add @import 'custom'  to the app.scss file in the src folder ot the dist folder. I do not know if this is what you are talking about but I don't break them up. I would think that you could but would have to use this method and I wouldn't think you couldn't add a folder to the layer of complexity.  I add mine right below the motion ui and it seems to work for me. https://www.youtube.com/watch?v=t_ekdBMj4cc

John Stephanites commented on John Stephanites's post almost 4 years

Thanks for the reply. I should have been more clear. I am just starting out with sass and I have been using another framework. I wanted to use Yeti to launch that project without Foundation sass files but with all the files I already have. I have been having a hard time getting that project launched through terminal because I do not have it set up properly using Compass ect. Yeti does all that for you but as far as I can tell the only way to launch a sass project is with their template. So all that said can I just redirect it to my already initiated project? Am I explaining this right?Thanks again!

John Stephanites commented on kostas's post almost 4 years

I thought they were helpful. The template just showed me,someone new to foundation, what to do. Gave me a kickoff point. I would imagine if you have used a lot of different frameworks they wouldn't mean to much but I have only used Bootstrap so this got me going in the right direction.

John Stephanites commented on John Stephanites's post almost 4 years

No I don't want a template. Those are clearly presented on the foundation site.

Posts Followed


  • 1
    Reply
  • Orbit and Wow.js

    By Ryan Patterson

    Orbitwow.js

    Hello Foundation Community, I know this maybe more of a Wow.js question, but was hoping someone has run into a similar issue.  I have an orbit slider. I set the main image as the slides background. I have a div inside the slide that has a backgroun... (continued)

    Last Reply by John Stephanites over 2 years ago



  • 14
    Replies
  • html templates

    By kostas

    html templates

    hi, I have installed foundation with sass for sites. i am trying to use HTML templates: http://foundation.zurb.com/templates.html when i download one of them i only get the html file. i was wondering where can i find the whole package of files with ... (continued)

    Last Reply by aniket singh about 2 years ago



Following

    No Content

Followers

My Posts






My Comments

You commented on Zurb Rules's post over 2 years

I was having the same problem but with JPEG. Align-middle on the parent didn't work. I finally used text-center on the direct parent div and that worked. I don't know why because I had tried that but when I changed the whole parent grid from grid-margin-x to grid-padding-x it worked. 

You commented on John Stephanites's post over 2 years

As it turns out it is very simple. I wanted to center some text in a div and all you do is add a class="text-center". Or if using Flexbox .   https://codepen.io/rafibomb/pen/YNerMQ
.flex-container {
text-align: center;

}

You commented on John Stephanites's post over 2 years

I just said I found the answer.

You commented on John Stephanites's post over 2 years

It has nothing on that page about centering like I am talking about. I actually found the answer using Dash by Kapeli. I do not know how to get to those kind of docs from the foundation site.

You commented on Ryan Patterson's post over 2 years

Would a loop work? Every time slide one fires then restart?  I don't know as my JS skills suck but just wondering.

You commented on Derek Paul's post over 2 years

I have been running into problems lately with the gulp process not recognizing my chances. Sometimes I have to go as far as shutting it down and restarting and even that doesn't work. Sounds very similar. If you figure it out let me know please. Thanks.

You commented on Derek Paul's post over 2 years

I put the _custom.scss in the src-> assets->scss folder and then you need to add @import 'custom'  to the app.scss file in the src folder ot the dist folder. I do not know if this is what you are talking about but I don't break them up. I would think that you could but would have to use this method and I wouldn't think you couldn't add a folder to the layer of complexity.  I add mine right below the motion ui and it seems to work for me. https://www.youtube.com/watch?v=t_ekdBMj4cc

You commented on John Stephanites's post almost 4 years

Thanks for the reply. I should have been more clear. I am just starting out with sass and I have been using another framework. I wanted to use Yeti to launch that project without Foundation sass files but with all the files I already have. I have been having a hard time getting that project launched through terminal because I do not have it set up properly using Compass ect. Yeti does all that for you but as far as I can tell the only way to launch a sass project is with their template. So all that said can I just redirect it to my already initiated project? Am I explaining this right?Thanks again!

You commented on kostas's post almost 4 years

I thought they were helpful. The template just showed me,someone new to foundation, what to do. Gave me a kickoff point. I would imagine if you have used a lot of different frameworks they wouldn't mean to much but I have only used Bootstrap so this got me going in the right direction.

You commented on John Stephanites's post almost 4 years

No I don't want a template. Those are clearly presented on the foundation site.

Posts Followed

Following

  • No Content

Followers

  • No Content