Menu icon Foundation

Developer

My Posts






My Comments

Sebastian Sulinski commented on Joop Vos's post over 4 years

Sorry - yes - either directly inside of the file bower_components/foundation/scss/foundation/components/_top-bar.scss or in any file that follows it (can overwrite the definitions).

In that file you'll find the line that reads:

// Top Bar styles intended for screen sizes above the breakpoint.
    @media #{$topbar-media-query} {

You should place this code within that section - so that it only applies to the layout above the break point (when the navigation is displayed in full rather than mobile format).

Sebastian Sulinski commented on Sebastian Sulinski's post almost 5 years

Yes, but it would be nice to have it as a native feature rather than doing additional work arounds - like AngularJS for instance.

Sebastian Sulinski commented on Luca Bianco's post almost 5 years

What solved the problem for me was the bower update - simply run the following in terminal:

bower update

And then try to install new foundation project.

Sebastian Sulinski commented on Sebastian Sulinski's post about 5 years

I also tried to set up new foundation project on Centos 6.5 - and got the following:
```
Creating ./test
create test
remote: Counting objects: 105, done.
remote: Total 105 (delta 0), reused 0 (delta 0)
Receiving objects: 100% (105/105), 38.20 KiB, done.
Resolving deltas: 100% (39/39), done.
Installing dependencies with bower...
bower ESUDO Cannot be run with sudo

Additional error details:
Since bower is a user command, there is no need to execute it with superuser permissions.
If you're having permission errors when using bower without sudo, please spend a few minutes learning more about how your system should work and make any necessary repairs.

http://www.joyent.com/blog/installing-node-and-npm
https://gist.github.com/isaacs/579814

You can however run a command with sudo using --allow-root option
/usr/local/rvm/gems/ruby-2.1.3/gems/foundation-1.0.4/lib/foundation/cli/generator.rb:131:in read': No such file or directory @ rb_sysopen - /home/projects/public_html/system/public_html/test/bower_components/foundation/scss/foundation/_settings.scss (Errno::ENOENT)
from /usr/local/rvm/gems/ruby-2.1.3/gems/foundation-1.0.4/lib/foundation/cli/generator.rb:131:in
block (2 levels) in new'
from /usr/local/rvm/gems/ruby-2.1.3/gems/foundation-1.0.4/lib/foundation/cli/generator.rb:131:in open'
from /usr/local/rvm/gems/ruby-2.1.3/gems/foundation-1.0.4/lib/foundation/cli/generator.rb:131:in
block in new'
from /usr/local/rvm/gems/ruby-2.1.3/gems/thor-0.19.1/lib/thor/actions.rb:184:in block in inside'
from /usr/local/rvm/rubies/ruby-2.1.3/lib/ruby/2.1.0/fileutils.rb:125:in
chdir'
from /usr/local/rvm/rubies/ruby-2.1.3/lib/ruby/2.1.0/fileutils.rb:125:in cd'
from /usr/local/rvm/gems/ruby-2.1.3/gems/thor-0.19.1/lib/thor/actions.rb:184:in
inside'
from /usr/local/rvm/gems/ruby-2.1.3/gems/foundation-1.0.4/lib/foundation/cli/generator.rb:128:in new'
from /usr/local/rvm/gems/ruby-2.1.3/gems/thor-0.19.1/lib/thor/command.rb:27:in
run'
from /usr/local/rvm/gems/ruby-2.1.3/gems/thor-0.19.1/lib/thor/invocation.rb:126:in invoke_command'
from /usr/local/rvm/gems/ruby-2.1.3/gems/thor-0.19.1/lib/thor.rb:359:in
dispatch'
from /usr/local/rvm/gems/ruby-2.1.3/gems/thor-0.19.1/lib/thor/base.rb:440:in start'
from /usr/local/rvm/gems/ruby-2.1.3/gems/foundation-1.0.4/bin/foundation:4:in
'
from /usr/local/rvm/gems/ruby-2.1.3/bin/foundation:23:in load'
from /usr/local/rvm/gems/ruby-2.1.3/bin/foundation:23:in
'
from /usr/local/rvm/gems/ruby-2.1.3/bin/ruby_executable_hooks:15:in eval'
from /usr/local/rvm/gems/ruby-2.1.3/bin/ruby_executable_hooks:15:in
'

Sebastian Sulinski commented on Sebastian Sulinski's post about 5 years

And when I try to run it with --libsass I get:
```
Creating ./test
create test
Cloning into 'test'...
remote: Counting objects: 154, done.
remote: Total 154 (delta 0), reused 0 (delta 0)
Receiving objects: 100% (154/154), 232.22 KiB | 0 bytes/s, done.
Resolving deltas: 100% (51/51), done.
Checking connectivity... done.
Installing dependencies with bower...
run npm install from "./test"
npm WARN package.json [email protected] No repository field.
npm ERR! Error: EACCES, mkdir '/Users/Sebastian/.npm/glob/3.1.21'
npm ERR! { [Error: EACCES, mkdir '/Users/Sebastian/.npm/glob/3.1.21']
npm ERR! errno: 3,
npm ERR! code: 'EACCES',
npm ERR! path: '/Users/Sebastian/.npm/glob/3.1.21',
npm ERR! parent: 'globule' }
npm ERR!
npm ERR! Please try running this command again as root/Administrator.

npm ERR! System Darwin 10.8.0
npm ERR! command "node" "/usr/local/bin/npm" "install"
npm ERR! cwd /Users/Sebastian/Downloads/test
npm ERR! node -v v0.10.32
npm ERR! npm -v 1.4.28
npm ERR! path /Users/Sebastian/.npm/glob/3.1.21
npm ERR! code EACCES
npm ERR! errno 3
npm ERR! stack Error: EACCES, mkdir '/Users/Sebastian/.npm/glob/3.1.21'
npm ERR! not ok code 0
run grunt build from "./test"
grunt-cli: The grunt command line interface. (v0.1.13)

Fatal error: Unable to find local grunt.

If you're seeing this message, either a Gruntfile wasn't found or grunt
hasn't been installed locally to your project. For more information about
installing and configuring grunt, please see the Getting Started guide:

http://gruntjs.com/getting-started
./test was created
```

Sebastian Sulinski commented on Sebastian Sulinski's post about 5 years

This didn't fix the problem with the duplication of the _global declarations.

Sebastian Sulinski commented on Greg Blass's post about 5 years

I was experiencing similar issue - what fixed it for me was to set up the width of the ul container with the data-orbit attribute to 100%. Give it a try and see if if works for you too.

Sebastian Sulinski commented on Joop Vos's post over 5 years

Probably worth adding that these should be applied to

@media #{$topbar-media-query}

(above the breakpoint) - otherwise on mobile devices your navigation will be centered and won't fill in the full width of the screen because of the inline-block

Sebastian Sulinski commented on John Mehl's post over 5 years

I've noticed, after having the same problem - that when I change 'variable_height' to false (which I believe is default setting) then it sorted the problem my end, plus I've also used this recommendation: https://github.com/zurb/foundation/issues/4938#issuecomment-41520590

Sebastian Sulinski commented on NIkos V's post over 5 years

I have the same problem with google maps - it makes it much higher than defined height on the iframe - at least double the height. Any idea what might be causing it?

Posts Followed



Following

    No Content

Followers

My Posts

My Comments

You commented on Joop Vos's post over 4 years

Sorry - yes - either directly inside of the file bower_components/foundation/scss/foundation/components/_top-bar.scss or in any file that follows it (can overwrite the definitions).

In that file you'll find the line that reads:

// Top Bar styles intended for screen sizes above the breakpoint.
    @media #{$topbar-media-query} {

You should place this code within that section - so that it only applies to the layout above the break point (when the navigation is displayed in full rather than mobile format).

You commented on Sebastian Sulinski's post almost 5 years

Yes, but it would be nice to have it as a native feature rather than doing additional work arounds - like AngularJS for instance.

You commented on Luca Bianco's post almost 5 years

What solved the problem for me was the bower update - simply run the following in terminal:

bower update

And then try to install new foundation project.

You commented on Sebastian Sulinski's post about 5 years

I also tried to set up new foundation project on Centos 6.5 - and got the following:
```
Creating ./test
create test
remote: Counting objects: 105, done.
remote: Total 105 (delta 0), reused 0 (delta 0)
Receiving objects: 100% (105/105), 38.20 KiB, done.
Resolving deltas: 100% (39/39), done.
Installing dependencies with bower...
bower ESUDO Cannot be run with sudo

Additional error details:
Since bower is a user command, there is no need to execute it with superuser permissions.
If you're having permission errors when using bower without sudo, please spend a few minutes learning more about how your system should work and make any necessary repairs.

http://www.joyent.com/blog/installing-node-and-npm
https://gist.github.com/isaacs/579814

You can however run a command with sudo using --allow-root option
/usr/local/rvm/gems/ruby-2.1.3/gems/foundation-1.0.4/lib/foundation/cli/generator.rb:131:in read': No such file or directory @ rb_sysopen - /home/projects/public_html/system/public_html/test/bower_components/foundation/scss/foundation/_settings.scss (Errno::ENOENT)
from /usr/local/rvm/gems/ruby-2.1.3/gems/foundation-1.0.4/lib/foundation/cli/generator.rb:131:in
block (2 levels) in new'
from /usr/local/rvm/gems/ruby-2.1.3/gems/foundation-1.0.4/lib/foundation/cli/generator.rb:131:in open'
from /usr/local/rvm/gems/ruby-2.1.3/gems/foundation-1.0.4/lib/foundation/cli/generator.rb:131:in
block in new'
from /usr/local/rvm/gems/ruby-2.1.3/gems/thor-0.19.1/lib/thor/actions.rb:184:in block in inside'
from /usr/local/rvm/rubies/ruby-2.1.3/lib/ruby/2.1.0/fileutils.rb:125:in
chdir'
from /usr/local/rvm/rubies/ruby-2.1.3/lib/ruby/2.1.0/fileutils.rb:125:in cd'
from /usr/local/rvm/gems/ruby-2.1.3/gems/thor-0.19.1/lib/thor/actions.rb:184:in
inside'
from /usr/local/rvm/gems/ruby-2.1.3/gems/foundation-1.0.4/lib/foundation/cli/generator.rb:128:in new'
from /usr/local/rvm/gems/ruby-2.1.3/gems/thor-0.19.1/lib/thor/command.rb:27:in
run'
from /usr/local/rvm/gems/ruby-2.1.3/gems/thor-0.19.1/lib/thor/invocation.rb:126:in invoke_command'
from /usr/local/rvm/gems/ruby-2.1.3/gems/thor-0.19.1/lib/thor.rb:359:in
dispatch'
from /usr/local/rvm/gems/ruby-2.1.3/gems/thor-0.19.1/lib/thor/base.rb:440:in start'
from /usr/local/rvm/gems/ruby-2.1.3/gems/foundation-1.0.4/bin/foundation:4:in
'
from /usr/local/rvm/gems/ruby-2.1.3/bin/foundation:23:in load'
from /usr/local/rvm/gems/ruby-2.1.3/bin/foundation:23:in
'
from /usr/local/rvm/gems/ruby-2.1.3/bin/ruby_executable_hooks:15:in eval'
from /usr/local/rvm/gems/ruby-2.1.3/bin/ruby_executable_hooks:15:in
'

You commented on Sebastian Sulinski's post about 5 years

And when I try to run it with --libsass I get:
```
Creating ./test
create test
Cloning into 'test'...
remote: Counting objects: 154, done.
remote: Total 154 (delta 0), reused 0 (delta 0)
Receiving objects: 100% (154/154), 232.22 KiB | 0 bytes/s, done.
Resolving deltas: 100% (51/51), done.
Checking connectivity... done.
Installing dependencies with bower...
run npm install from "./test"
npm WARN package.json [email protected] No repository field.
npm ERR! Error: EACCES, mkdir '/Users/Sebastian/.npm/glob/3.1.21'
npm ERR! { [Error: EACCES, mkdir '/Users/Sebastian/.npm/glob/3.1.21']
npm ERR! errno: 3,
npm ERR! code: 'EACCES',
npm ERR! path: '/Users/Sebastian/.npm/glob/3.1.21',
npm ERR! parent: 'globule' }
npm ERR!
npm ERR! Please try running this command again as root/Administrator.

npm ERR! System Darwin 10.8.0
npm ERR! command "node" "/usr/local/bin/npm" "install"
npm ERR! cwd /Users/Sebastian/Downloads/test
npm ERR! node -v v0.10.32
npm ERR! npm -v 1.4.28
npm ERR! path /Users/Sebastian/.npm/glob/3.1.21
npm ERR! code EACCES
npm ERR! errno 3
npm ERR! stack Error: EACCES, mkdir '/Users/Sebastian/.npm/glob/3.1.21'
npm ERR! not ok code 0
run grunt build from "./test"
grunt-cli: The grunt command line interface. (v0.1.13)

Fatal error: Unable to find local grunt.

If you're seeing this message, either a Gruntfile wasn't found or grunt
hasn't been installed locally to your project. For more information about
installing and configuring grunt, please see the Getting Started guide:

http://gruntjs.com/getting-started
./test was created
```

You commented on Sebastian Sulinski's post about 5 years

This didn't fix the problem with the duplication of the _global declarations.

You commented on Greg Blass's post about 5 years

I was experiencing similar issue - what fixed it for me was to set up the width of the ul container with the data-orbit attribute to 100%. Give it a try and see if if works for you too.

You commented on Joop Vos's post over 5 years

Probably worth adding that these should be applied to

@media #{$topbar-media-query}

(above the breakpoint) - otherwise on mobile devices your navigation will be centered and won't fill in the full width of the screen because of the inline-block

You commented on John Mehl's post over 5 years

I've noticed, after having the same problem - that when I change 'variable_height' to false (which I believe is default setting) then it sorted the problem my end, plus I've also used this recommendation: https://github.com/zurb/foundation/issues/4938#issuecomment-41520590

You commented on NIkos V's post over 5 years

I have the same problem with google maps - it makes it much higher than defined height on the iframe - at least double the height. Any idea what might be causing it?

Posts Followed

Following

  • No Content

Followers

  • No Content