Menu icon Foundation

Coder | johor bahru

My Posts


My Comments

rozani commented on rozani's post almost 6 years

Ok. Nevermind.

I already solved the Bower installing problem in Linux Mint Olivia on my own by referring to the link : http://developwithguru.com/how-to-install-node-js-and-npm-in-ubuntu-or-mint/

Bower only works with nodejs (stable)
By default, npm branch in Debian Package Manager will bundle with nodejs-dev

I remove the nodejs-dev which already bundled in npm.

rozani commented on rozani's post almost 6 years

If you want to help me, please DO NOT SIMPLY just copy paste the code from the foundation doc. It does NOT help me.

I'm stuck at npm install -g bower . Cannot install bower in Linux Mint Olivia.
Please understand the error I got and please HELP me.

After i put the code in terminal, npm install -g bower

I had the same ERROR :

 rozani@rozani-Aspire-4937 ~ $ npm install -g bower
npm http GET https://registry.npmjs.org/bower
npm http 304 https://registry.npmjs.org/bower

npm ERR! Error: No compatible version found: bower
npm ERR! No valid targets found.
npm ERR! Perhaps not compatible with your version of node?
npm ERR!     at installTargetsError (/usr/share/npm/lib/cache.js:488:10)
npm ERR!     at next_ (/usr/share/npm/lib/cache.js:438:17)
npm ERR!     at next (/usr/share/npm/lib/cache.js:415:44)
npm ERR!     at /usr/share/npm/lib/cache.js:408:5
npm ERR!     at saved (/usr/share/npm/lib/utils/npm-registry-client/get.js:147:7)
npm ERR!     at Object.oncomplete (/usr/lib/nodejs/graceful-fs.js:230:7)
npm ERR! You may report this log at:
npm ERR!     <http://bugs.debian.org/npm>
npm ERR! or use
npm ERR!     reportbug --attach /home/rozani/npm-debug.log npm
npm ERR! 
npm ERR! System Linux 3.8.0-19-generic
npm ERR! command "/usr/bin/nodejs" "/usr/bin/npm" "install" "-g" "bower"
npm ERR! cwd /home/rozani
npm ERR! node -v v0.6.19
npm ERR! npm -v 1.1.4
npm ERR! message No compatible version found: bower
npm ERR! message No valid targets found.
npm ERR! message Perhaps not compatible with your version of node?

npm ERR! Error: EACCES, open 'npm-debug.log'
npm ERR! 
npm ERR! Please try running this command again as root/Administrator.
npm ERR! 
npm ERR! System Linux 3.8.0-19-generic
npm ERR! command "/usr/bin/nodejs" "/usr/bin/npm" "install" "-g" "bower"
npm ERR! cwd /home/rozani
npm ERR! node -v v0.6.19
npm ERR! npm -v 1.1.4
npm ERR! path npm-debug.log
npm ERR! code EACCES
npm ERR! message EACCES, open 'npm-debug.log'
npm ERR! errno {}
npm ERR! 
npm ERR! Additional logging details can be found in:
npm ERR!     /home/rozani/npm-debug.log
npm not ok

rozani commented on rozani's post almost 6 years

This is the error I get during installing bower in Linux Mint. How to resolve this?
Please help me.

 rozani-Aspire-4937 rozani # npm install -g bower
npm http GET https://registry.npmjs.org/bower
npm http 304 https://registry.npmjs.org/bower

npm ERR! Error: No compatible version found: bower
npm ERR! No valid targets found.
npm ERR! Perhaps not compatible with your version of node?
npm ERR!     at installTargetsError (/usr/share/npm/lib/cache.js:488:10)
npm ERR!     at next_ (/usr/share/npm/lib/cache.js:438:17)
npm ERR!     at next (/usr/share/npm/lib/cache.js:415:44)
npm ERR!     at /usr/share/npm/lib/cache.js:408:5
npm ERR!     at saved (/usr/share/npm/lib/utils/npm-registry-client/get.js:147:7)
npm ERR!     at Object.oncomplete (/usr/lib/nodejs/graceful-fs.js:230:7)
npm ERR! You may report this log at:
npm ERR!     <http://bugs.debian.org/npm>
npm ERR! or use
npm ERR!     reportbug --attach /home/rozani/npm-debug.log npm
npm ERR! 
npm ERR! System Linux 3.8.0-19-generic
npm ERR! command "/usr/bin/nodejs" "/usr/bin/npm" "install" "-g" "bower"
npm ERR! cwd /home/rozani
npm ERR! node -v v0.6.19
npm ERR! npm -v 1.1.4
npm ERR! message No compatible version found: bower
npm ERR! message No valid targets found.
npm ERR! message Perhaps not compatible with your version of node?
npm ERR! 
npm ERR! Additional logging details can be found in:
npm ERR!     /home/rozani/npm-debug.log
npm not ok
rozani-Aspire-4937 rozani #

rozani commented on rozani's post almost 6 years

Here the link for the gem.

http://rubygems.org/search?utf8=%E2%9C%93&query=foundation

I used both gem foundation and gem zurb-foundation, both are foundation 4.3.2 and not foundation 5.

I cannot find any new gem for foundation 5.

I follow the foundation doc but I cannot install bower. I believe the doc about sass is all rubbish.

There are too many complain for bower from year 2012, zurb should maintain using ruby gem.

Bower have many compatibility with OS such as Debian LMDE, Ubuntu etc.

I love Zurb Foundation 5 but I really hate Zurb forcing users to use Bower.

Posts Followed

No Content

Following

    No Content

Followers

My Posts

My Comments

You commented on rozani's post almost 6 years

Ok. Nevermind.

I already solved the Bower installing problem in Linux Mint Olivia on my own by referring to the link : http://developwithguru.com/how-to-install-node-js-and-npm-in-ubuntu-or-mint/

Bower only works with nodejs (stable)
By default, npm branch in Debian Package Manager will bundle with nodejs-dev

I remove the nodejs-dev which already bundled in npm.

You commented on rozani's post almost 6 years

If you want to help me, please DO NOT SIMPLY just copy paste the code from the foundation doc. It does NOT help me.

I'm stuck at npm install -g bower . Cannot install bower in Linux Mint Olivia.
Please understand the error I got and please HELP me.

After i put the code in terminal, npm install -g bower

I had the same ERROR :

 rozani@rozani-Aspire-4937 ~ $ npm install -g bower
npm http GET https://registry.npmjs.org/bower
npm http 304 https://registry.npmjs.org/bower

npm ERR! Error: No compatible version found: bower
npm ERR! No valid targets found.
npm ERR! Perhaps not compatible with your version of node?
npm ERR!     at installTargetsError (/usr/share/npm/lib/cache.js:488:10)
npm ERR!     at next_ (/usr/share/npm/lib/cache.js:438:17)
npm ERR!     at next (/usr/share/npm/lib/cache.js:415:44)
npm ERR!     at /usr/share/npm/lib/cache.js:408:5
npm ERR!     at saved (/usr/share/npm/lib/utils/npm-registry-client/get.js:147:7)
npm ERR!     at Object.oncomplete (/usr/lib/nodejs/graceful-fs.js:230:7)
npm ERR! You may report this log at:
npm ERR!     <http://bugs.debian.org/npm>
npm ERR! or use
npm ERR!     reportbug --attach /home/rozani/npm-debug.log npm
npm ERR! 
npm ERR! System Linux 3.8.0-19-generic
npm ERR! command "/usr/bin/nodejs" "/usr/bin/npm" "install" "-g" "bower"
npm ERR! cwd /home/rozani
npm ERR! node -v v0.6.19
npm ERR! npm -v 1.1.4
npm ERR! message No compatible version found: bower
npm ERR! message No valid targets found.
npm ERR! message Perhaps not compatible with your version of node?

npm ERR! Error: EACCES, open 'npm-debug.log'
npm ERR! 
npm ERR! Please try running this command again as root/Administrator.
npm ERR! 
npm ERR! System Linux 3.8.0-19-generic
npm ERR! command "/usr/bin/nodejs" "/usr/bin/npm" "install" "-g" "bower"
npm ERR! cwd /home/rozani
npm ERR! node -v v0.6.19
npm ERR! npm -v 1.1.4
npm ERR! path npm-debug.log
npm ERR! code EACCES
npm ERR! message EACCES, open 'npm-debug.log'
npm ERR! errno {}
npm ERR! 
npm ERR! Additional logging details can be found in:
npm ERR!     /home/rozani/npm-debug.log
npm not ok

You commented on rozani's post almost 6 years

This is the error I get during installing bower in Linux Mint. How to resolve this?
Please help me.

 rozani-Aspire-4937 rozani # npm install -g bower
npm http GET https://registry.npmjs.org/bower
npm http 304 https://registry.npmjs.org/bower

npm ERR! Error: No compatible version found: bower
npm ERR! No valid targets found.
npm ERR! Perhaps not compatible with your version of node?
npm ERR!     at installTargetsError (/usr/share/npm/lib/cache.js:488:10)
npm ERR!     at next_ (/usr/share/npm/lib/cache.js:438:17)
npm ERR!     at next (/usr/share/npm/lib/cache.js:415:44)
npm ERR!     at /usr/share/npm/lib/cache.js:408:5
npm ERR!     at saved (/usr/share/npm/lib/utils/npm-registry-client/get.js:147:7)
npm ERR!     at Object.oncomplete (/usr/lib/nodejs/graceful-fs.js:230:7)
npm ERR! You may report this log at:
npm ERR!     <http://bugs.debian.org/npm>
npm ERR! or use
npm ERR!     reportbug --attach /home/rozani/npm-debug.log npm
npm ERR! 
npm ERR! System Linux 3.8.0-19-generic
npm ERR! command "/usr/bin/nodejs" "/usr/bin/npm" "install" "-g" "bower"
npm ERR! cwd /home/rozani
npm ERR! node -v v0.6.19
npm ERR! npm -v 1.1.4
npm ERR! message No compatible version found: bower
npm ERR! message No valid targets found.
npm ERR! message Perhaps not compatible with your version of node?
npm ERR! 
npm ERR! Additional logging details can be found in:
npm ERR!     /home/rozani/npm-debug.log
npm not ok
rozani-Aspire-4937 rozani #

You commented on rozani's post almost 6 years

Here the link for the gem.

http://rubygems.org/search?utf8=%E2%9C%93&query=foundation

I used both gem foundation and gem zurb-foundation, both are foundation 4.3.2 and not foundation 5.

I cannot find any new gem for foundation 5.

I follow the foundation doc but I cannot install bower. I believe the doc about sass is all rubbish.

There are too many complain for bower from year 2012, zurb should maintain using ruby gem.

Bower have many compatibility with OS such as Debian LMDE, Ubuntu etc.

I love Zurb Foundation 5 but I really hate Zurb forcing users to use Bower.

Posts Followed

No Content

Following

  • No Content

Followers

  • No Content