Menu icon Foundation

Developer | East Maine, NY

I started programming in 1961. Have developed mainframe operating systems and electronic CAD applications. Started hand coding web sites in 1997 as a volunteer. Trying to move to web tools beyond a basic text editor.

My Posts


  • NEW
  • Posts Not Being Posted

    By Tom Elliott

    forumposts lost

    I have submitted some posts over the last few weeks but they are not appearing on the FoundationForum. They are on My Forum. Neither have I received any email notices since last year.   If this post should show up on the Foundation Form, can someon... (continued)


  • NEW
  • Can't sign up for lessons

    By Tom Elliott

    Lessons

    I used to get the weekly email with the Foundation lessons. They stopped coming last year. I've tried signing up again on the Unlock the Vault page but nothing happens. Is this service no longer in operation?  





  • NEW
  • Sticky Responsive Navigation Menu

    By Tom Elliott

    Stcky Navigation

    I am trying to make my responsive menu sticky on all sizes. I have reviewed the forum posts on this topic and have found some helpful information. Starting from scratch with the example Responsive Toggle code from https://foundation.zurb.com/sites/docs/r... (continued)


  • 5
    Replies
  • Node.js version warning

    By Tom Elliott

    foundation-clinode.js

    I have been posting about my problems getting foundation-cli running.   I discovered by rummaging through ReadMe files that node-sass, which is used by foundation-cli, does not support Node.js versions 8 and 9.   If you are starting from scr... (continued)

    Last Reply by jackyanke about 1 year ago



  • 7
    Replies
  • npm install failure

    By Tom Elliott

    installenoent

    I'm trying to install the latest version of foundation-sites. I am on Win 10 64bit.   This is the command window: ------------------------------------------------------------------ C:\wamp64\www>node -vv8.11.1C:\wamp64\www>npm -v5.6.0C:\wam... (continued)

    Last Reply by Tom Elliott over 1 year ago


My Comments

Tom Elliott commented on Tom Elliott's post over 1 year

Thanks.
Everything worked as advertised.
 
 

Tom Elliott commented on Tom Elliott's post over 1 year

 More information.
I installed node-sass by itself and copied the package into my project. All good.
I ran "foundation watch" and SASS started but failed because of:
-----------------
Error: Node Sass does not yet support your current environment: Windows 64-bit with Unsupported runtime (57).
For more information on which environments are supported please see:https://github.com/sass/node-sass/releases/tag/v3.13.1
I went to see the supported environments as suggested and found:
Supported Environments
 



OS
Architecture
Node




Windows
x86 & x64
0.10, 0.12, 1, 2, 3, 4, 5, 6,7



I am using the latest Node, version 9. Is there a SASS that I can install that will work? Or will I have to uninstall everything and back up to an obsolete Node version?
Full session follows:
-------------------------------------------------
C:\wamp64\www\t1>foundation watch> [email protected] start C:\wamp64\www\t1> gulp[17:37:55] Using gulpfile C:\wamp64\www\t1\gulpfile.js[17:37:55] Starting 'sass'...[17:37:55] 'sass' errored after 256 ms[17:37:55] Error: Node Sass does not yet support your current environment: Windows 64-bit with Unsupported runtime (57)For more information on which environments are supported please see:https://github.com/sass/node-sass/releases/tag/v3.13.1    at module.exports (C:\wamp64\www\t1\node_modules\gulp-sass\node_modules\node-sass\lib\binding.js:13:13)    at Object.<anonymous> (C:\wamp64\www\t1\node_modules\gulp-sass\node_modules\node-sass\lib\index.js:14:35)    at Module._compile (module.js:652:30)    at Object.Module._extensions..js (module.js:663:10)    at Module.load (module.js:565:32)    at tryModuleLoad (module.js:505:12)    at Function.Module._load (module.js:497:3)    at Module.require (module.js:596:17)    at require (internal/module.js:11:18)    at Object.<anonymous> (C:\wamp64\www\t1\node_modules\gulp-sass\index.js:187:21)Error: [email protected] start: gulpExit status 1    at EventEmitter.<anonymous> (C:\Users\Tom.NEWTOM\AppData\Roaming\npm\node_modules\foundation-cli\node_modules\npm\lib\utils\lifecycle.js:217:16)    at emitTwo (events.js:126:13)    at EventEmitter.emit (events.js:214:7)    at ChildProcess.<anonymous> (C:\Users\Tom.NEWTOM\AppData\Roaming\npm\node_modules\foundation-cli\node_modules\npm\lib\utils\spawn.js:24:14)    at emitTwo (events.js:126:13)    at ChildProcess.emit (events.js:214:7)    at maybeClose (internal/child_process.js:925:16)    at Process.ChildProcess._handle.onexit (internal/child_process.js:209:5)

Tom Elliott commented on Tom Elliott's post over 1 year

Thank you Daniel for your help. I had to go into my node-modules and delete the package before it worked, but now I'm good to go.

Tom Elliott commented on Tom Elliott's post over 1 year

Thanks Daniel. I never had to run those commands in F-5 through F6.3. Seemed to get a good install, but now I get this:
---------------------------------------------------------------------
Microsoft Windows [Version 10.0.16299.309](c) 2017 Microsoft Corporation. All rights reserved.c:\wamp64\www>npm install foundation-sites -s+ [email protected]updated 1 package in 22.719sc:\wamp64\www>foundation new'foundation' is not recognized as an internal or external command,operable program or batch file.c:\wamp64\www>---------------------------------------------------------------------------
Again, I never had this problem before.
I've tried rebooting to refresh the PATH. No joy.
 

Tom Elliott commented on Tom Elliott's post almost 3 years

OK, I found $anchor-color and it styles the menu items. However, I'm looking for a solution which is local to topbar and/or menu. Something like $topbar-anchor-color would do the trick.
$topbar-background propogates into the topbar contents. I'm seeking something similar for text colors.
$dropdownmenu-arrow-color handles the arrows in dropdown
 

Tom Elliott commented on Tom Elliott's post almost 3 years

 Thanks Rafi.
Just to clarify: The dependency is the 'flex' property, right?
 

Tom Elliott commented on Tom Elliott's post almost 3 years

Sorry, I have no experience with Wordpress.

Tom Elliott commented on Tom Elliott's post almost 4 years

Thanks, Rafi.

Is there a way to automatically have the images fill the box?

Tom Elliott commented on Tom Elliott's post almost 4 years

Yes, I eventually found it. My post was originally rejected, so I couldn't revise it.

Happy New Year!

Tom Elliott commented on Tom Elliott's post almost 4 years

Yes, that is the problem I am having. It is compounded by the problem described in http://foundation.zurb.com/forum/posts/37253-npm-modules . That is why I want to delete projects.

I will return to my original way of coding and just use the css and js files as resources. It seems to me that the framework components (node; etc.) used in the Foundation framework are not totally suitable in a Windows environment.

I have used the CoffeeCup editor for years and it has the ability to keep code snippets and library includes similar in function the handlebars function. Also, I understand what is going on. This is the way I use F5.

Posts Followed

  • 14
    Replies
  • Installing SASS

    By Tom Elliott

    Sass

    I did a complete installation of Foundation 5 (Download Everything) from http://foundation.zurb.com/develop/download.html. This works fine. I now want to customize using SASS. I followed the recommended installation steps for Git, Node, Ruby on http://... (continued)

    Last Reply by Queirozmano2 almost 3 years ago


Following

    No Content

Followers

My Posts









My Comments

You commented on Tom Elliott's post over 1 year

Thanks.
Everything worked as advertised.
 
 

You commented on Tom Elliott's post over 1 year

 More information.
I installed node-sass by itself and copied the package into my project. All good.
I ran "foundation watch" and SASS started but failed because of:
-----------------
Error: Node Sass does not yet support your current environment: Windows 64-bit with Unsupported runtime (57).
For more information on which environments are supported please see:https://github.com/sass/node-sass/releases/tag/v3.13.1
I went to see the supported environments as suggested and found:
Supported Environments
 



OS
Architecture
Node




Windows
x86 & x64
0.10, 0.12, 1, 2, 3, 4, 5, 6,7



I am using the latest Node, version 9. Is there a SASS that I can install that will work? Or will I have to uninstall everything and back up to an obsolete Node version?
Full session follows:
-------------------------------------------------
C:\wamp64\www\t1>foundation watch> [email protected] start C:\wamp64\www\t1> gulp[17:37:55] Using gulpfile C:\wamp64\www\t1\gulpfile.js[17:37:55] Starting 'sass'...[17:37:55] 'sass' errored after 256 ms[17:37:55] Error: Node Sass does not yet support your current environment: Windows 64-bit with Unsupported runtime (57)For more information on which environments are supported please see:https://github.com/sass/node-sass/releases/tag/v3.13.1    at module.exports (C:\wamp64\www\t1\node_modules\gulp-sass\node_modules\node-sass\lib\binding.js:13:13)    at Object.<anonymous> (C:\wamp64\www\t1\node_modules\gulp-sass\node_modules\node-sass\lib\index.js:14:35)    at Module._compile (module.js:652:30)    at Object.Module._extensions..js (module.js:663:10)    at Module.load (module.js:565:32)    at tryModuleLoad (module.js:505:12)    at Function.Module._load (module.js:497:3)    at Module.require (module.js:596:17)    at require (internal/module.js:11:18)    at Object.<anonymous> (C:\wamp64\www\t1\node_modules\gulp-sass\index.js:187:21)Error: [email protected] start: gulpExit status 1    at EventEmitter.<anonymous> (C:\Users\Tom.NEWTOM\AppData\Roaming\npm\node_modules\foundation-cli\node_modules\npm\lib\utils\lifecycle.js:217:16)    at emitTwo (events.js:126:13)    at EventEmitter.emit (events.js:214:7)    at ChildProcess.<anonymous> (C:\Users\Tom.NEWTOM\AppData\Roaming\npm\node_modules\foundation-cli\node_modules\npm\lib\utils\spawn.js:24:14)    at emitTwo (events.js:126:13)    at ChildProcess.emit (events.js:214:7)    at maybeClose (internal/child_process.js:925:16)    at Process.ChildProcess._handle.onexit (internal/child_process.js:209:5)

You commented on Tom Elliott's post over 1 year

Thank you Daniel for your help. I had to go into my node-modules and delete the package before it worked, but now I'm good to go.

You commented on Tom Elliott's post over 1 year

Thanks Daniel. I never had to run those commands in F-5 through F6.3. Seemed to get a good install, but now I get this:
---------------------------------------------------------------------
Microsoft Windows [Version 10.0.16299.309](c) 2017 Microsoft Corporation. All rights reserved.c:\wamp64\www>npm install foundation-sites -s+ [email protected]updated 1 package in 22.719sc:\wamp64\www>foundation new'foundation' is not recognized as an internal or external command,operable program or batch file.c:\wamp64\www>---------------------------------------------------------------------------
Again, I never had this problem before.
I've tried rebooting to refresh the PATH. No joy.
 

You commented on Tom Elliott's post almost 3 years

OK, I found $anchor-color and it styles the menu items. However, I'm looking for a solution which is local to topbar and/or menu. Something like $topbar-anchor-color would do the trick.
$topbar-background propogates into the topbar contents. I'm seeking something similar for text colors.
$dropdownmenu-arrow-color handles the arrows in dropdown
 

You commented on Tom Elliott's post almost 3 years

 Thanks Rafi.
Just to clarify: The dependency is the 'flex' property, right?
 

You commented on Tom Elliott's post almost 3 years

Sorry, I have no experience with Wordpress.

You commented on Tom Elliott's post almost 4 years

Thanks, Rafi.

Is there a way to automatically have the images fill the box?

You commented on Tom Elliott's post almost 4 years

Yes, I eventually found it. My post was originally rejected, so I couldn't revise it.

Happy New Year!

You commented on Tom Elliott's post almost 4 years

Yes, that is the problem I am having. It is compounded by the problem described in http://foundation.zurb.com/forum/posts/37253-npm-modules . That is why I want to delete projects.

I will return to my original way of coding and just use the css and js files as resources. It seems to me that the framework components (node; etc.) used in the Foundation framework are not totally suitable in a Windows environment.

I have used the CoffeeCup editor for years and it has the ability to keep code snippets and library includes similar in function the handlebars function. Also, I understand what is going on. This is the way I use F5.

Posts Followed


Following

  • No Content

Followers

  • No Content