Menu icon Foundation

My Posts











My Comments

Dennis commented on YH's post 11 months

I think you should take a look at the selectTab method of Foundation. https://foundation.zurb.com/sites/docs/tabs.html#selecttab

Dennis commented on sean peterson's post 11 months

You have to add the functionallity by yourself. The Foundation 6 pagination is just HTML and CSS only.

Dennis commented on christian hernandez's post over 1 year

First you have to initialize the Foundation framework in the document ready code: 
 
$(document).foundation();
 
"it needs a few page reloads to work properly."
Probably because of browser caching

Dennis commented on Francisco Curros Bastit's post over 1 year

"jQuery' is undefined" means that jQuery is not included (In the right way).
You should load the jQuery library before you load the Foundation library, then it should work.

Dennis commented on bill's post over 1 year

Maybe this can help you?

Dennis commented on Julia G's post over 1 year

It is possible but without an code example we can't guess whats wrong.

Dennis commented on Jay Todtenbier's post over 1 year

Upgrading from Foundation 5 to Foundation 6 is a huge step. I did this too and ended up in a lot of issues the very first period. Almost eveything has changed in Foundation 6 so think about it before you decide to upgrade. It will take a lot of time, ofcourse also it depends how big the site is.
 
But... upgrading to Foundation 6 is totally worth. A lot of benefits I experience right now, such as the code is reduced significally, many bug fixes, new components, pretty good support etc...

Dennis commented on Glenn Philp's post over 1 year

Never saw that method with the astriks before, learned someting new today :)
 
So if the AJAX returns what you expected then it looks like appending the data to the modal fails altough your code looks fine to me and the Foundation docs.
 
Do you have an codepen/fiddle example?

Dennis commented on Glenn Philp's post over 1 year

"Synchronous XMLHttpRequest on the main thread.." is a warning not a error and is not releated for filling your modal.
The problem is related in the return of your AJAX call. Undefined is obvious the reason of your whole problem. It seems the URL of the AJAX call is wrong.
Why do you use an astriks (*) in the URL? Looks wrong to me though

Dennis commented on The Amigo's post over 1 year

You need a little bit jQuery for version 6 of Foundation, like this example.

Posts Followed





  • 2
    Replies
  • Sticky on small only?

    By bill

    sticky

    Is there an option for the sticky plugin to make it sticky on small screens ONLY?  Right now, if I use data-sticky-on="small" it seems to stick on all screen sizes. 

    Last Reply by bill over 1 year ago


  • 5
    Replies
  • Problem with several Reveal modals

    By Julia G

    F6revealiframe

    Hey, somehow my post was removed as spam. Trying again, hopefully I can get some answers instead. I'll omit the code in case it was perceived as spam, but it's really very basic. I'm using Foundation 6. I have several reveal modals on the page, each cont... (continued)

    Last Reply by Julia G over 1 year ago




  • 7
    Replies
  • Modal content from other page

    By The Amigo

    modal

    Can i create a modal that hold content from another page in my project? this not work: <a href="signup.aspx" class="small button" data-reveal-id="TestSignup" data-reveal-ajax="true">Signup</a> <div id="TestModal" class="reveal" data-reve... (continued)

    Last Reply by Dennis over 1 year ago



Following

    No Content

Followers

My Posts

My Comments

You commented on YH's post 11 months

I think you should take a look at the selectTab method of Foundation. https://foundation.zurb.com/sites/docs/tabs.html#selecttab

You commented on sean peterson's post 11 months

You have to add the functionallity by yourself. The Foundation 6 pagination is just HTML and CSS only.

You commented on christian hernandez's post over 1 year

First you have to initialize the Foundation framework in the document ready code: 
 
$(document).foundation();
 
"it needs a few page reloads to work properly."
Probably because of browser caching

You commented on Francisco Curros Bastit's post over 1 year

"jQuery' is undefined" means that jQuery is not included (In the right way).
You should load the jQuery library before you load the Foundation library, then it should work.

You commented on bill's post over 1 year

Maybe this can help you?

You commented on Julia G's post over 1 year

It is possible but without an code example we can't guess whats wrong.

You commented on Jay Todtenbier's post over 1 year

Upgrading from Foundation 5 to Foundation 6 is a huge step. I did this too and ended up in a lot of issues the very first period. Almost eveything has changed in Foundation 6 so think about it before you decide to upgrade. It will take a lot of time, ofcourse also it depends how big the site is.
 
But... upgrading to Foundation 6 is totally worth. A lot of benefits I experience right now, such as the code is reduced significally, many bug fixes, new components, pretty good support etc...

You commented on Glenn Philp's post over 1 year

Never saw that method with the astriks before, learned someting new today :)
 
So if the AJAX returns what you expected then it looks like appending the data to the modal fails altough your code looks fine to me and the Foundation docs.
 
Do you have an codepen/fiddle example?

You commented on Glenn Philp's post over 1 year

"Synchronous XMLHttpRequest on the main thread.." is a warning not a error and is not releated for filling your modal.
The problem is related in the return of your AJAX call. Undefined is obvious the reason of your whole problem. It seems the URL of the AJAX call is wrong.
Why do you use an astriks (*) in the URL? Looks wrong to me though

You commented on The Amigo's post over 1 year

You need a little bit jQuery for version 6 of Foundation, like this example.

Posts Followed

Following

  • No Content

Followers

  • No Content