Menu icon Foundation

My Posts







My Comments

Douglas F commented on Douglas F's post over 4 years

Hi Rafi,

A couple problems I ran into with the code provided. When you load up the codepen, you'll notice the buttons have a solid background of black. Be awesome if these could be transparent.

Screenshot: http://i.imgur.com/zeDdgFU.jpg

Also when you scrolldown in the codepen, and then scroll back up, you'll notice it's about 50% opacity (the background). I would love if it was like it was originally with 0% background colour. Screenshot attached.

Screenshot: http://i.imgur.com/qdGeoNU.jpg

Can you please provide a quickfix? Would really appreciate it!

Thank you,
D

Douglas F commented on Douglas F's post over 4 years

Libsass is installed, node is also installed.

When using Grunt on the freshly installed Foundation project that I was working on at work, it works on my work PC. When using Grunt on that same file on my Macbook, it doesn't work.

The weird thing is that, I just tested the Grunt process on a freshly installed Foundation project as per the Libsass and Grunt instructions for sass in the Foundation docs, on my Mac, and it works...

So how does creating a fresh new Foundation project, using the same instructions on the Foundation docs through lib-sass and grunt work fine on a PC - however using that SAME project on my Mac, going into command line, navigating to the folder and hitting "grunt" to watch the sass files, brings up an error?

As stated above, I just downloaded Foundation though lib-sass / grunt instructions onto my Mac, and it works fine (navigating to the folder through command line, typing "grunt" and it watches the sass files fine). But this one from my work (which was downloaded a day before, using the exact same Grunt method to watch sass files), doesn't work?

Edit - Prepros doesn't work for either projects (the one I created at work, nor the new Foundation copy I just downloaded).

Douglas F commented on Bit Byte's post over 4 years

You don't need anything but the HTML, JS and CSS files. You can leave out the SASS, Node.js, Bower and Grunt files are they are only needed during development.

Although, I would still include them in the upload incase you're on another machine and want to download all files from FTP and work on them.

Douglas F commented on Douglas F's post over 4 years

Rafi,

My apologies. It works perfectly in Firefox, but not in Chrome. It seems that in Chrome, the styles aren't loading properly.

Thank you for this!

Douglas F commented on Douglas F's post over 4 years

The effect is non-existent in that codepen. Any other references?

Douglas F commented on Douglas F's post over 4 years

FIgured it out!

Added this code..

<div class="container" role="document">
      <div class="row">

To the following pages:

single.php, index.php - JUST BELOW the php get header tag.

Hope that helps anyone that may get stuck with this in the future!

Douglas F commented on Douglas F's post over 4 years

Didn't work (source: http://i.imgur.com/Ll5g8ow.png).

Any other ideas to get this image full-width?

Keep in mind that in header.php, there is this code:
HTML
<!-- Start the main container -->
<div class="container" role="document">
<div class="row">

And in footer.php, this container ends. This container 'contains' everything in the entire website. I need full-width to some items within this container.

Posts Followed


Following

    No Content

Followers

My Posts

My Comments

You commented on Douglas F's post over 4 years

Hi Rafi,

A couple problems I ran into with the code provided. When you load up the codepen, you'll notice the buttons have a solid background of black. Be awesome if these could be transparent.

Screenshot: http://i.imgur.com/zeDdgFU.jpg

Also when you scrolldown in the codepen, and then scroll back up, you'll notice it's about 50% opacity (the background). I would love if it was like it was originally with 0% background colour. Screenshot attached.

Screenshot: http://i.imgur.com/qdGeoNU.jpg

Can you please provide a quickfix? Would really appreciate it!

Thank you,
D

You commented on Douglas F's post over 4 years

Libsass is installed, node is also installed.

When using Grunt on the freshly installed Foundation project that I was working on at work, it works on my work PC. When using Grunt on that same file on my Macbook, it doesn't work.

The weird thing is that, I just tested the Grunt process on a freshly installed Foundation project as per the Libsass and Grunt instructions for sass in the Foundation docs, on my Mac, and it works...

So how does creating a fresh new Foundation project, using the same instructions on the Foundation docs through lib-sass and grunt work fine on a PC - however using that SAME project on my Mac, going into command line, navigating to the folder and hitting "grunt" to watch the sass files, brings up an error?

As stated above, I just downloaded Foundation though lib-sass / grunt instructions onto my Mac, and it works fine (navigating to the folder through command line, typing "grunt" and it watches the sass files fine). But this one from my work (which was downloaded a day before, using the exact same Grunt method to watch sass files), doesn't work?

Edit - Prepros doesn't work for either projects (the one I created at work, nor the new Foundation copy I just downloaded).

You commented on Bit Byte's post over 4 years

You don't need anything but the HTML, JS and CSS files. You can leave out the SASS, Node.js, Bower and Grunt files are they are only needed during development.

Although, I would still include them in the upload incase you're on another machine and want to download all files from FTP and work on them.

You commented on Douglas F's post over 4 years

Rafi,

My apologies. It works perfectly in Firefox, but not in Chrome. It seems that in Chrome, the styles aren't loading properly.

Thank you for this!

You commented on Douglas F's post over 4 years

The effect is non-existent in that codepen. Any other references?

You commented on Douglas F's post over 4 years

FIgured it out!

Added this code..

<div class="container" role="document">
      <div class="row">

To the following pages:

single.php, index.php - JUST BELOW the php get header tag.

Hope that helps anyone that may get stuck with this in the future!

You commented on Douglas F's post over 4 years

Didn't work (source: http://i.imgur.com/Ll5g8ow.png).

Any other ideas to get this image full-width?

Keep in mind that in header.php, there is this code:
HTML
<!-- Start the main container -->
<div class="container" role="document">
<div class="row">

And in footer.php, this container ends. This container 'contains' everything in the entire website. I need full-width to some items within this container.

Posts Followed

Following

  • No Content

Followers

  • No Content