Menu icon Foundation

My Posts






  • 2
    Replies
  • gotta love Zurb

    By Robin Cox

    lovezurbhorsethank you

    I got a thank you letter with a bunch of nice stickers from zurb just for pointing out that there were lots of spam on this forum for about a month ago. The thing that made me happiest was that there was a hand sketched "dala horse" whitch is a typical sw... (continued)

    Last Reply by Rafi Benkual over 3 years ago





My Comments

Robin Cox commented on Robin Cox's post over 2 years

Found it!

Add: data-options="is_hover: false"

here:

<nav class="top-bar" data-topbar role="navigation" data-options="is_hover: false">

Robin Cox commented on Robin Cox's post over 3 years

After some research I think I have the answer.

Seems that because my file "headerMedium.php" is loaded via javaScript, it has no connection to Wordpress thus don't know what "get_template_directory_uri()" is.

Robin Cox commented on Robin Cox's post over 3 years

Hi Esa, it's only wordpress functions that won't work. It works if I echo out the full path with php.

Robin Cox commented on Noah Breen's post over 3 years

As Jonathan and Karl says, it's no biggie with that validation error, I say ignore it.

But if you wan't your document to validate and still use interchange for images, why not set interchane on a div instead and load different html documents containing different images dependable on your conditions? like this for example:

<div data-interchange="[../smallimage.html, small], [../mediumimage.html, medium], [../largeimage.html, large]">
    // this happens if the none of you conditions are met.
</div>

Robin Cox commented on Robin Cox's post over 3 years

Thanks flexbox, but it's not only for that specific case. The problem is that I have to use !important for other stuff to. I wan't all my scss rules to supercede the default foundation ones.

Robin Cox commented on Daniel Acree's post over 3 years

I have this problem too and as Karl suggests it gets more lag if the main content has heavy content.

Robin Cox commented on Tom Gates's post over 3 years

Modernizr adds the class .touch to the html tag on devices with touch screens. So to target a div with the class "custom-div-name", do this:

html.touch .custom-div-name {
key: value;
}

(note the spacing between html.touch and .custom-div-name)

Robin Cox commented on Karl Ward's post over 3 years

@Daniel Acree it's even a bit sluggish on my desctop chrome.

Anyway, thats one hell of a nice site you got there :)

Robin Cox commented on Robin Cox's post over 3 years

On the iPhone, where the problem occurs, I'm using safari.

Robin Cox commented on Karl Ward's post over 3 years

That produces this error for me:

Undefined mixin ´Transform´

Posts Followed

No Content

Following

    No Content

Followers

My Posts

My Comments

You commented on Robin Cox's post over 2 years

Found it!

Add: data-options="is_hover: false"

here:

<nav class="top-bar" data-topbar role="navigation" data-options="is_hover: false">

You commented on Robin Cox's post over 3 years

After some research I think I have the answer.

Seems that because my file "headerMedium.php" is loaded via javaScript, it has no connection to Wordpress thus don't know what "get_template_directory_uri()" is.

You commented on Robin Cox's post over 3 years

Hi Esa, it's only wordpress functions that won't work. It works if I echo out the full path with php.

You commented on Noah Breen's post over 3 years

As Jonathan and Karl says, it's no biggie with that validation error, I say ignore it.

But if you wan't your document to validate and still use interchange for images, why not set interchane on a div instead and load different html documents containing different images dependable on your conditions? like this for example:

<div data-interchange="[../smallimage.html, small], [../mediumimage.html, medium], [../largeimage.html, large]">
    // this happens if the none of you conditions are met.
</div>

You commented on Robin Cox's post over 3 years

Thanks flexbox, but it's not only for that specific case. The problem is that I have to use !important for other stuff to. I wan't all my scss rules to supercede the default foundation ones.

You commented on Daniel Acree's post over 3 years

I have this problem too and as Karl suggests it gets more lag if the main content has heavy content.

You commented on Tom Gates's post over 3 years

Modernizr adds the class .touch to the html tag on devices with touch screens. So to target a div with the class "custom-div-name", do this:

html.touch .custom-div-name {
key: value;
}

(note the spacing between html.touch and .custom-div-name)

You commented on Karl Ward's post over 3 years

@Daniel Acree it's even a bit sluggish on my desctop chrome.

Anyway, thats one hell of a nice site you got there :)

You commented on Robin Cox's post over 3 years

On the iPhone, where the problem occurs, I'm using safari.

You commented on Karl Ward's post over 3 years

That produces this error for me:

Undefined mixin ´Transform´

Posts Followed

No Content

Following

  • No Content

Followers