Menu icon Foundation

My Posts

No Content

My Comments

Marc Guay commented on Bor Kolaric's post over 3 years

Coming across this problem myself.  It seems that if you do something like the following in settings:
$align-block-grid-to-grid: true;
@if $align-block-grid-to-grid {$block-grid-default-spacing: rem-calc(5);}
The value of $block-grid-default-spacing will be ignored/overidden in block-grid.scss here:
@if $align-block-grid-to-grid {
$block-grid-default-spacing: $column-gutter;
}
And be reset to $column-gutter...
Update:  reason is because the setting in block-grid.scss is missing !default, posted a fix here https://github.com/zurb/foundation-sites/pull/8405.

Marc Guay commented on Frederic Bouin's post about 4 years

Unfortunately this only seems to work if the column being vertically centered is on the left. Switching it to the right causes it to display on the left (being positioned absolutely inside the row without a "left" or "right" definition).

Marc Guay commented on b c's post over 4 years
Marc Guay commented on Hammy Goonan's post over 4 years

Juergen, my project is also a Magento site. Can you let me know if/when you figure this out?

Marc Guay commented on Hammy Goonan's post almost 5 years

Commenting out line 141 in foundation.interchange.js solves the issue for me. I realize that this is not a solution but a clue.

passed.el.trigger(passed.scenario[1], args); 

For the original poster, perhaps removing the src attribute from your HTML will help your first problem. The docs, at least for v5, don't instruct to include it.

Marc

Marc Guay commented on Hammy Goonan's post almost 5 years

I have run into the same issue with the img element being removed from the DOM after what looks like a successful run through interchange.

Posts Followed



  • 5
    Replies
  • onchange event called multiple times

    By b c

    slideronchange

    I found that the onchange handler for a slider I created was executed 4 times upon first loading of the webpage, and at least twice for each time the slider was moved. Is this expected behaviour? I'd rather not have the the onchange event execute a... (continued)

    Last Reply by Marc Guay over 4 years ago


Following

    No Content

Followers

My Posts

No Content

My Comments

You commented on Bor Kolaric's post over 3 years

Coming across this problem myself.  It seems that if you do something like the following in settings:
$align-block-grid-to-grid: true;
@if $align-block-grid-to-grid {$block-grid-default-spacing: rem-calc(5);}
The value of $block-grid-default-spacing will be ignored/overidden in block-grid.scss here:
@if $align-block-grid-to-grid {
$block-grid-default-spacing: $column-gutter;
}
And be reset to $column-gutter...
Update:  reason is because the setting in block-grid.scss is missing !default, posted a fix here https://github.com/zurb/foundation-sites/pull/8405.

You commented on Frederic Bouin's post about 4 years

Unfortunately this only seems to work if the column being vertically centered is on the left. Switching it to the right causes it to display on the left (being positioned absolutely inside the row without a "left" or "right" definition).

You commented on b c's post over 4 years
You commented on Hammy Goonan's post over 4 years

Juergen, my project is also a Magento site. Can you let me know if/when you figure this out?

You commented on Hammy Goonan's post almost 5 years

Commenting out line 141 in foundation.interchange.js solves the issue for me. I realize that this is not a solution but a clue.

passed.el.trigger(passed.scenario[1], args); 

For the original poster, perhaps removing the src attribute from your HTML will help your first problem. The docs, at least for v5, don't instruct to include it.

Marc

You commented on Hammy Goonan's post almost 5 years

I have run into the same issue with the img element being removed from the DOM after what looks like a successful run through interchange.

Posts Followed

Following

  • No Content

Followers

  • No Content