Menu icon Foundation

My Posts

No Content

My Comments

Phil T. commented on Kelvin's post almost 5 years

I'm about to try Foundation for Apps. But it seems that your 'Getting Started' guide is currently broken.

Executing (as mentioned in step 3)

npm start 

exits with the following error:

Error: Cannot find module 'amdefine'
at Function.Module._resolveFilename (module.js:338:15)
at Function.Module._load (module.js:280:25)
at Module.require (module.js:364:17)
at require (module.js:380:17)
at Object. (/Users/pt/Dev/Temp/tmp/foundationApp/node_modules/gulp-uglify/node_modules/uglify-js/node_modules/source-map/lib/source-map/source-map-generator.js:8:18)
at Module._compile (module.js:456:26)
at Object.Module._extensions..js (module.js:474:10)
at Module.load (module.js:356:32)
at Function.Module._load (module.js:312:12)
at Module.require (module.js:364:17)

I've already updated my node, npm, ruby and bundler versions. So it really seems that executing the default gulp task is kinda broken. Unfortunately, I don't have the time to dig deeper right now in order to investigate the problem and provide a PR. But just wanted to inform you.

Bye,
Phil

Posts Followed

No Content

Following

    No Content

Followers

My Posts

No Content

My Comments

You commented on Kelvin's post almost 5 years

I'm about to try Foundation for Apps. But it seems that your 'Getting Started' guide is currently broken.

Executing (as mentioned in step 3)

npm start 

exits with the following error:

Error: Cannot find module 'amdefine'
at Function.Module._resolveFilename (module.js:338:15)
at Function.Module._load (module.js:280:25)
at Module.require (module.js:364:17)
at require (module.js:380:17)
at Object. (/Users/pt/Dev/Temp/tmp/foundationApp/node_modules/gulp-uglify/node_modules/uglify-js/node_modules/source-map/lib/source-map/source-map-generator.js:8:18)
at Module._compile (module.js:456:26)
at Object.Module._extensions..js (module.js:474:10)
at Module.load (module.js:356:32)
at Function.Module._load (module.js:312:12)
at Module.require (module.js:364:17)

I've already updated my node, npm, ruby and bundler versions. So it really seems that executing the default gulp task is kinda broken. Unfortunately, I don't have the time to dig deeper right now in order to investigate the problem and provide a PR. But just wanted to inform you.

Bye,
Phil

Posts Followed

No Content

Following

  • No Content

Followers

  • No Content