Menu icon Foundation

My Posts



My Comments

Lef commented on Patrick Holzer's post almost 4 years

Hi,

Wen you finished development, you can enter the following command in yeti-launch:
$ npm run build

This should execute 'gulp build' with -production flag.

Unfortunately this isn't working for me. I get an error:

 dyld: Symbol not found: _node_module_register
  Referenced from: /Applications/MAMP/htdocs/zurb/node_modules/browser-sync/node_modules/socket.io/node_modules/engine.io/node_modules/ws/node_modules/bufferutil/build/Release/bufferutil.node
  Expected in: dynamic lookup

see also: http://foundation.zurb.com/forum/posts/36351-error-building-for-production

Please let me know if this is working for you. Curious :)

Lef commented on Lef's post almost 5 years

Hi,

Any updates on this one?

thx!!!

Lef commented on Lef's post almost 5 years

Hi Rafi, thx for the quick reply. Just tried your solution, but unfortunately it is not working.

I am using the hide-for-xlarge-up, because the viewport of my ipad 2 in landscape view (1024px) is part of the $xlarge-range breakpoint which I defined myself.

These are my breakpoints:

$small-range: (0em, 25em); 
$medium-range: (25.063em, 40.375em);
$large-range: (40.4375em, 54,375em);
$xlarge-range: (54.4375em, 120em);

So in this case my iPad 2 in Landscape belongs to the $xlarge-range. Which means it should hide the offcanvas-menu.

Like I said it works great in simulators (chrome element inspector) and when I resize my browser, but not on the device itself.

Any other ideas?

thx!

Posts Followed

  • 1
    Reply
  • How to proceed from Yeti to live site?

    By Patrick Holzer

    yeti

    Hi, I've started using Yeti and it's working great but I'm not clear on this: Once I've completed development in Yeti, how do I proceed? I expected Yeti to offer some sort of "export site"-function which would provide me with a "ready to upload to t... (continued)

    Last Reply by Lef almost 4 years ago


Following

    No Content

Followers

My Posts

My Comments

You commented on Patrick Holzer's post almost 4 years

Hi,

Wen you finished development, you can enter the following command in yeti-launch:
$ npm run build

This should execute 'gulp build' with -production flag.

Unfortunately this isn't working for me. I get an error:

 dyld: Symbol not found: _node_module_register
  Referenced from: /Applications/MAMP/htdocs/zurb/node_modules/browser-sync/node_modules/socket.io/node_modules/engine.io/node_modules/ws/node_modules/bufferutil/build/Release/bufferutil.node
  Expected in: dynamic lookup

see also: http://foundation.zurb.com/forum/posts/36351-error-building-for-production

Please let me know if this is working for you. Curious :)

You commented on Lef's post almost 5 years

Hi,

Any updates on this one?

thx!!!

You commented on Lef's post almost 5 years

Hi Rafi, thx for the quick reply. Just tried your solution, but unfortunately it is not working.

I am using the hide-for-xlarge-up, because the viewport of my ipad 2 in landscape view (1024px) is part of the $xlarge-range breakpoint which I defined myself.

These are my breakpoints:

$small-range: (0em, 25em); 
$medium-range: (25.063em, 40.375em);
$large-range: (40.4375em, 54,375em);
$xlarge-range: (54.4375em, 120em);

So in this case my iPad 2 in Landscape belongs to the $xlarge-range. Which means it should hide the offcanvas-menu.

Like I said it works great in simulators (chrome element inspector) and when I resize my browser, but not on the device itself.

Any other ideas?

thx!

Posts Followed


Following

  • No Content

Followers

  • No Content