Menu icon Foundation

My Posts


My Comments

Robert Truex commented on Tonybyte's post over 2 years

I updated to bower 1.8.0, npm 5.3.0 and foundation 2.2.3. I'm not great with CLI, I had to install and update things and eventually got it working. Sorry I can't be more helpful.
 

Robert Truex commented on Tonybyte's post over 2 years

I tried all kinds of uninstall/install/updating. It seemed like when I updated Bower -g  that foundation-cli started working properly.

Robert Truex commented on Tonybyte's post over 2 years

I am having this same issue after updating foundation-cli from 2.1.0 to current.

Robert Truex commented on Robert Truex's post almost 4 years

The above seems to work but uses $(document).foundation(); instead of just reflowing the toggler plugin in my small partial. Neither of the two commented out lines worked. I also get the following JS warning:
'''
Tried to initialize interchange on an element that already has a Foundation plugin.
'''

Robert Truex commented on Robert Truex's post almost 4 years

It looks like the following seems to work...now to figure out if i can just get the toggler inside small partial to reinit/reflow instead of calling the entire foundation();...

$(document).ready(function() {

  $("#masthead-wrapper").on("replaced.zf.interchange", function() {
    console.log("zf interchange: replaced masthead partial");
    var currentBreakpoint = Foundation.MediaQuery.current;
    if (currentBreakpoint === "small") {
      //$(document).foundation();
      //$(document).foundation('reflow');
      //$(document).foundation('toggler','reflow');
    }
  });  

});

Robert Truex commented on Kari's post about 5 years

Thank you Briar, setting equalize_on_stack: true for equalizer during Foundation Init as you posted solved the issue.
Javascript
$(document).foundation({
equalizer: {
equalize_on_stack: true
}
});

Posts Followed



Following

    No Content

Followers

My Posts

My Comments

You commented on Tonybyte's post over 2 years

I updated to bower 1.8.0, npm 5.3.0 and foundation 2.2.3. I'm not great with CLI, I had to install and update things and eventually got it working. Sorry I can't be more helpful.
 

You commented on Tonybyte's post over 2 years

I tried all kinds of uninstall/install/updating. It seemed like when I updated Bower -g  that foundation-cli started working properly.

You commented on Tonybyte's post over 2 years

I am having this same issue after updating foundation-cli from 2.1.0 to current.

You commented on Robert Truex's post almost 4 years

The above seems to work but uses $(document).foundation(); instead of just reflowing the toggler plugin in my small partial. Neither of the two commented out lines worked. I also get the following JS warning:
'''
Tried to initialize interchange on an element that already has a Foundation plugin.
'''

You commented on Robert Truex's post almost 4 years

It looks like the following seems to work...now to figure out if i can just get the toggler inside small partial to reinit/reflow instead of calling the entire foundation();...

$(document).ready(function() {

  $("#masthead-wrapper").on("replaced.zf.interchange", function() {
    console.log("zf interchange: replaced masthead partial");
    var currentBreakpoint = Foundation.MediaQuery.current;
    if (currentBreakpoint === "small") {
      //$(document).foundation();
      //$(document).foundation('reflow');
      //$(document).foundation('toggler','reflow');
    }
  });  

});

You commented on Kari's post about 5 years

Thank you Briar, setting equalize_on_stack: true for equalizer during Foundation Init as you posted solved the issue.
Javascript
$(document).foundation({
equalizer: {
equalize_on_stack: true
}
});

Posts Followed

Following

  • No Content

Followers

  • No Content