Menu icon Foundation

Developer | Aargau, Switzerland

Unix developer

My Posts



My Comments

Marc Balmer commented on Marc Balmer's post about 5 years

The reason is that foundation.css defines tables to have a fixed cell size:

table {
table-layout: fixed;
}

Changing this in my own CSS file to

table {
table-layout: auto;
}

solves the issue.

Marc Balmer commented on ndh's post about 5 years

Ok, I found the root cause. foundation.css has this

table {
table-layout: fixed;

This means that tables load faster, but don't auto resize.

So either override this in your own CSS or add style="table-layout: auto" to you definitions.

Marc Balmer commented on ndh's post about 5 years

The underlying problem seems to be that table cells are of equal width. try to see the effect.

I don't know yet how this behavior can be turned off, though.

Marc Balmer commented on ndh's post about 5 years

Having issues with tables as well. See my earlier post as well. For me, table content is totally garbled, see the screen shot in my post.

It looks like table cells are no longer automatically sized depending on their content.

Posts Followed

  • 8
    Replies
  • Tables look different in 5.4

    By ndh

    tables5.4

    I just upgraded from 5.0 to 5.4 and now my tables look completely different. The problem seems to be how the first column is displayed. Were there any changes to tables? The first image shows how my table used to look. The second shows the table in 5.4. Thank you

    Last Reply by moflixsallinone about 5 years ago



Following

    No Content

Followers

My Posts

My Comments

You commented on Marc Balmer's post about 5 years

The reason is that foundation.css defines tables to have a fixed cell size:

table {
table-layout: fixed;
}

Changing this in my own CSS file to

table {
table-layout: auto;
}

solves the issue.

You commented on ndh's post about 5 years

Ok, I found the root cause. foundation.css has this

table {
table-layout: fixed;

This means that tables load faster, but don't auto resize.

So either override this in your own CSS or add style="table-layout: auto" to you definitions.

You commented on ndh's post about 5 years

The underlying problem seems to be that table cells are of equal width. try to see the effect.

I don't know yet how this behavior can be turned off, though.

You commented on ndh's post about 5 years

Having issues with tables as well. See my earlier post as well. For me, table content is totally garbled, see the screen shot in my post.

It looks like table cells are no longer automatically sized depending on their content.

Posts Followed


Following

  • No Content

Followers

  • No Content