Menu icon Foundation
Problems with -ms-flex-align

Hello everybody,

I am building a new WordPress theme, for which I am using the css-version of Foundation 6.3.1 (I know, I know... there are some good reasons in this case). I thought I should use Flex Grid. However, I found that part of the css is ignored by the browser (Firefox 51) in my sandbox. Parts of foundation.css are missing in the representation of foundation.css shown by the Firefox developer tools Style Editor. In particular this is the case for all menu class rule sets.

Further investigation showed me that foundation.css includes 13 style properties -ms-flex-align. For example, line 908: .input-group {...  -ms-flex-align: stretch; ...}. My text editor (Adobe Brackets) indicates that there is something wrong with these. On the Microsoft Developer Network, -ms-flex-align seems to be unknown.

When I comment-out the -ms-flex-align style properties, everything is working - but maybe not on (older) IE versions...

Am I doing something wrong? Is this a known bug? Any comments and suggestions are welcome.

flex grid-ms-flex-align

Hello everybody,

I am building a new WordPress theme, for which I am using the css-version of Foundation 6.3.1 (I know, I know... there are some good reasons in this case). I thought I should use Flex Grid. However, I found that part of the css is ignored by the browser (Firefox 51) in my sandbox. Parts of foundation.css are missing in the representation of foundation.css shown by the Firefox developer tools Style Editor. In particular this is the case for all menu class rule sets.

Further investigation showed me that foundation.css includes 13 style properties -ms-flex-align. For example, line 908: .input-group {...  -ms-flex-align: stretch; ...}. My text editor (Adobe Brackets) indicates that there is something wrong with these. On the Microsoft Developer Network, -ms-flex-align seems to be unknown.

When I comment-out the -ms-flex-align style properties, everything is working - but maybe not on (older) IE versions...

Am I doing something wrong? Is this a known bug? Any comments and suggestions are welcome.

Henk Barreveld 5 months ago

In the meantime I found that there seem to be more problematic -ms- style properties. I switched to the non-Flex Grid, but it would still be nice to be able to use Flex Grid...