Menu icon Foundation
Mailchimp layout issue

Hi,

 

I used Foundation for emails in order to create my email template but I am experiencing layout issues when I am importing it in Mailchimp :

My content is streched and is 100% wide whereas it was in a container when I was coding it.

I tried to import it as zip and html after the "run npm build" command but without success.

 

If necessary I can upload my code.

 

Thanks in advance !

Excuse my English, French user here ! 

mailchimpissuebuglayoutcontent

Hi,

 

I used Foundation for emails in order to create my email template but I am experiencing layout issues when I am importing it in Mailchimp :

My content is streched and is 100% wide whereas it was in a container when I was coding it.

I tried to import it as zip and html after the "run npm build" command but without success.

 

If necessary I can upload my code.

 

Thanks in advance !

Excuse my English, French user here ! 

Rafi Benkual 6 months ago

Hi Jeremy,

have a picture of the issue so we can help you more?

Usually images that are too large cause it. Try adding a width to see if it resolves it

<img class="logo" src="assets/img/ZURB-U-logo.png" width="160" style="width: 160px!important;" alt="ZURB logo">

Sandra Vu 6 months ago

Hi Rafi

I am having a similar issue with Mailchimp also. The layout broke apart when sent via Mailchimp.

I did a test with Email on Acid sent from both Mailchimp and Campaign Monitor. (Email on Acid is a tool to examine how your email looks across devices.)

The email sent from Campaign Monitor turns out fine. The layout is good. 

The email sent from Mailchimp messed up totally re layout. I found the Mailchimp record of the HTML codes they sent out. Here it is: 

https://s3.amazonaws.com/myporfolio/Troubleshoot/Mailchimp.html

Here is the original code of my final build:

https://s3.amazonaws.com/myporfolio/Troubleshoot/Final+Build.html

Obviously, Mailchimp stripped out something from my code. I could not figure out which ones, though.

Looking forward to your answer!

Sandra

 

 

Steven Till 5 months ago

Hey Sandra,

Have you tried renaming Final+Build.html to Final-Build.html? I believe "+" is an invalid character for file and directory naming conventions.

 

8^)