Menu icon Foundation
setting up with foundation

I'm trying to get foundation to recognize the newer version of ruby I have installed (2.2) but it keeps pathing into 1.8.7 and I'm trying to figure out how to change the path to point to the right destination. Im getting this error:

/System/Library/Frameworks/Ruby.framework/Versions/1.8/usr/lib/ruby/1.8/rubygems.rb:777:in `report_activate_error': Could not find RubyGem foundation (>= 0) (Gem::LoadError)
    from /System/Library/Frameworks/Ruby.framework/Versions/1.8/usr/lib/ruby/1.8/rubygems.rb:211:in `activate'
	from /System/Library/Frameworks/Ruby.framework/Versions/1.8/usr/lib/ruby/1.8/rubygems.rb:1056:in `gem'
	from /usr/bin/foundation:18
            

         

Hopefully if I can get this working, it will be up and runing because I've had a lot of trouble getting foundation up on OSX 10.7. Is it much more difficult to get everything up on a fresh OSX 10.7 (older system is why im using it) and should i just go to 10.8 which I should be able to handle. Also, the xcode and developer tools are an older version could that be a problem in getting foundation up.

set-up

I'm trying to get foundation to recognize the newer version of ruby I have installed (2.2) but it keeps pathing into 1.8.7 and I'm trying to figure out how to change the path to point to the right destination. Im getting this error:

/System/Library/Frameworks/Ruby.framework/Versions/1.8/usr/lib/ruby/1.8/rubygems.rb:777:in `report_activate_error': Could not find RubyGem foundation (>= 0) (Gem::LoadError)
    from /System/Library/Frameworks/Ruby.framework/Versions/1.8/usr/lib/ruby/1.8/rubygems.rb:211:in `activate'
	from /System/Library/Frameworks/Ruby.framework/Versions/1.8/usr/lib/ruby/1.8/rubygems.rb:1056:in `gem'
	from /usr/bin/foundation:18
            

         

Hopefully if I can get this working, it will be up and runing because I've had a lot of trouble getting foundation up on OSX 10.7. Is it much more difficult to get everything up on a fresh OSX 10.7 (older system is why im using it) and should i just go to 10.8 which I should be able to handle. Also, the xcode and developer tools are an older version could that be a problem in getting foundation up.

Rafi Benkual almost 2 years ago

If you run ruby -v, what version is it?

also, did you run gem install foundation?